View Issue Details

IDProjectCategoryView StatusLast Update
0031670Lazarus-public2018-01-07 09:29
Reporternoname012 Assigned ToMichl  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS10 
Target Version1.7 (SVN) 
Summary0031670: Caption in TGroupBox with Enabled=False
DescriptionWhen a GroupBox is Disabled (ex. GroupBox1.Enabled=False),
a second caption is showed under.
Steps To ReproduceIn Lazarus 1.9.0 (revision>=54600) create a new Form and drop a GroupBox component, than set GroupBox1.Enabled=False. A second caption is showed under
Additional InformationLazarus 1.9.0 revision=54599 does not have this issue.
The problem probably is in
http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=revision&root=lazarus&revision=54600
TagsNo tags attached.
Fixed in Revisionr54623 r54624
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0031635 closedJuha Manninen Patches Range check error in ComboBoxWindowProc 
related to 0027491 resolvedMichl Lazarus TGroupBox.Caption not greyed when disabled on Windows 

Activities

noname012

2017-04-16 19:43

reporter  

TGroupBox1.png (8,712 bytes)   
TGroupBox1.png (8,712 bytes)   

Bart Broersma

2017-04-16 22:49

developer   ~0099635

Maybe related to 0027491 ?

Michl

2017-04-17 12:05

developer   ~0099639

Last edited: 2017-04-17 12:16

View 2 revisions

Is it OK, if I assign this issue to me (it is imho more related to 0027491)?!

Michl

2017-04-17 12:09

developer   ~0099640

Last edited: 2017-04-17 12:13

View 3 revisions

The reason for that problem seems to be getdc returns now client window DC. Changing to Windows.GetDC fixes that issue (line 544 in unit Win32WSStdCtrls.pp).

Juha Manninen

2017-04-17 12:53

developer   ~0099641

Michl, yes I am happy if you take over this issue.

Michl

2017-04-17 13:38

developer   ~0099642

Last edited: 2017-04-17 14:00

View 2 revisions

Fixed in trunk revision 54623, in 1.8RC1 revision 54624. Please test and close if OK.

Issue History

Date Modified Username Field Change
2017-04-16 19:43 noname012 New Issue
2017-04-16 19:43 noname012 File Added: TGroupBox1.png
2017-04-16 22:49 Bart Broersma Note Added: 0099635
2017-04-17 09:54 Juha Manninen Relationship added related to 0031635
2017-04-17 09:54 Juha Manninen Assigned To => Juha Manninen
2017-04-17 09:54 Juha Manninen Status new => assigned
2017-04-17 12:05 Michl Relationship added related to 0027491
2017-04-17 12:05 Michl Note Added: 0099639
2017-04-17 12:09 Michl Note Added: 0099640
2017-04-17 12:11 Michl Note Edited: 0099640 View Revisions
2017-04-17 12:13 Michl Note Edited: 0099640 View Revisions
2017-04-17 12:16 Michl Note Edited: 0099639 View Revisions
2017-04-17 12:51 Juha Manninen Assigned To Juha Manninen => Michl
2017-04-17 12:53 Juha Manninen Note Added: 0099641
2017-04-17 13:38 Michl Fixed in Revision => r54623
2017-04-17 13:38 Michl LazTarget => -
2017-04-17 13:38 Michl Note Added: 0099642
2017-04-17 13:38 Michl Status assigned => resolved
2017-04-17 13:38 Michl Resolution open => fixed
2017-04-17 13:38 Michl Target Version => 1.7 (SVN)
2017-04-17 13:59 Michl Status resolved => assigned
2017-04-17 13:59 Michl Resolution fixed => reopened
2017-04-17 14:00 Michl Note Edited: 0099642 View Revisions
2017-04-17 14:01 Michl Fixed in Revision r54623 => r54623 r54624
2017-04-17 14:01 Michl Status assigned => resolved
2017-04-17 14:01 Michl Resolution reopened => fixed
2018-01-07 09:29 noname012 Status resolved => closed