View Issue Details

IDProjectCategoryView StatusLast Update
0031697LazarusWidgetsetpublic2017-05-02 22:09
ReporterRoger OlssonAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebianOS Version9
Product Version1.9 (SVN)Product Build54677M 
Target Version1.8Fixed in Version1.9 (SVN) 
Summary0031697: TCheckListBox.OnSelectionChange never fires
DescriptionSelecting a ChecklistBox item doesn't fire the SelectionChange event.
Neither mouse or scrolling using keyboard makes the event fire.

Under Windows it works fine. At least in a virtualbox session.
Steps To ReproduceRun and scroll the box in attached demo.
TagsNo tags attached.
Fixed in Revision54696,54697,54707,54802
LazTarget1.8
WidgetsetGTK 2, QT, QT5
Attached Files

Relationships

related to 0020501 assignedMike Thompson Deleting selected item in TListBox.Items does not trigger TListBox.OnSelectionChange 

Activities

Roger Olsson

2017-04-23 01:11

reporter  

CheckListBoxDemo.zip (128,187 bytes)

Bart Broersma

2017-04-23 11:24

developer   ~0099800

Does TListBox behave as expected?

Roger Olsson

2017-04-23 13:55

reporter   ~0099813

Yes, OnSelectionChange of TListBox works.

Bart Broersma

2017-04-23 18:02

developer   ~0099835

Confirmed on Linux-GTK2 and Linux-QT (32-bit).

Roger Olsson

2017-04-23 20:49

reporter   ~0099841

OnSelectionChange can be triggered by code

lbWeekdays.Selected[1] := True;

But doesn't react to selection by mouse or keyboard.

Zeljan Rikalo

2017-04-23 21:20

developer   ~0099842

Qt and Qt5 are fixed with 54696.

Zeljan Rikalo

2017-04-23 21:21

developer   ~0099843

Leave opened because of Gtk2.

Zeljan Rikalo

2017-04-23 21:22

developer   ~0099844

Added Qt5 too.

Zeljan Rikalo

2017-04-23 21:46

developer   ~0099845

Gtk2 is also fixed. Please test and close if ok, also make some tests so it can be included in 1.8 fixes.

Roger Olsson

2017-04-24 01:05

reporter   ~0099847

GTK2: Works. Thank you!
QT: Works, except item 0 in the list doesn't fire the first time it is clicked. Seems to be selected already, but not marked blue? Therefore do not fire? Click another item and from then on all items trigger OnSelectionChange.
QT5: Can't test. Lazarus doesn't compile as qt5 for me.

Zeljan Rikalo

2017-04-24 12:16

developer   ~0099852

Please test and close if ok. Added additional patch for first time click.

Roger Olsson

2017-04-25 03:35

reporter   ~0099891

Works fine, so I close this now. Thanks again.

Roger Olsson

2017-04-25 03:37

reporter   ~0099892

Issue solved

Zeljan Rikalo

2017-05-02 22:08

developer   ~0100068

Reopened because of regression fix

Zeljan Rikalo

2017-05-02 22:09

developer   ~0100069

Regression with Qt/Qt5 from r54696 is fixed with r54802

Issue History

Date Modified Username Field Change
2017-04-23 01:11 Roger Olsson New Issue
2017-04-23 01:11 Roger Olsson File Added: CheckListBoxDemo.zip
2017-04-23 11:23 Bart Broersma Relationship added related to 0020501
2017-04-23 11:24 Bart Broersma LazTarget => -
2017-04-23 11:24 Bart Broersma Note Added: 0099800
2017-04-23 11:24 Bart Broersma Status new => feedback
2017-04-23 13:55 Roger Olsson Note Added: 0099813
2017-04-23 13:55 Roger Olsson Status feedback => new
2017-04-23 18:02 Bart Broersma Note Added: 0099835
2017-04-23 18:02 Bart Broersma Status new => confirmed
2017-04-23 18:14 Bart Broersma Widgetset GTK 2 => GTK 2, QT
2017-04-23 18:14 Bart Broersma Category LCL => Widgetset
2017-04-23 18:14 Bart Broersma Summary OnSelectionChange never fires => TCheckListBox.OnSelectionChange never fires
2017-04-23 20:49 Roger Olsson Note Added: 0099841
2017-04-23 21:20 Zeljan Rikalo Fixed in Revision => 54696
2017-04-23 21:20 Zeljan Rikalo Note Added: 0099842
2017-04-23 21:20 Zeljan Rikalo Status confirmed => resolved
2017-04-23 21:20 Zeljan Rikalo Resolution open => fixed
2017-04-23 21:20 Zeljan Rikalo Assigned To => Zeljan Rikalo
2017-04-23 21:21 Zeljan Rikalo Note Added: 0099843
2017-04-23 21:21 Zeljan Rikalo Assigned To Zeljan Rikalo =>
2017-04-23 21:21 Zeljan Rikalo Status resolved => confirmed
2017-04-23 21:22 Zeljan Rikalo Widgetset GTK 2, QT => GTK 2, QT, QT5
2017-04-23 21:22 Zeljan Rikalo Note Added: 0099844
2017-04-23 21:46 Zeljan Rikalo Fixed in Revision 54696 => 54696,54697
2017-04-23 21:46 Zeljan Rikalo Note Added: 0099845
2017-04-23 21:46 Zeljan Rikalo Status confirmed => resolved
2017-04-23 21:46 Zeljan Rikalo Assigned To => Zeljan Rikalo
2017-04-24 01:05 Roger Olsson Note Added: 0099847
2017-04-24 12:16 Zeljan Rikalo Status resolved => assigned
2017-04-24 12:16 Zeljan Rikalo Resolution fixed => reopened
2017-04-24 12:16 Zeljan Rikalo Fixed in Revision 54696,54697 => 54696,54697,54707
2017-04-24 12:16 Zeljan Rikalo Note Added: 0099852
2017-04-24 12:16 Zeljan Rikalo Status assigned => resolved
2017-04-24 12:16 Zeljan Rikalo Resolution reopened => fixed
2017-04-25 03:35 Roger Olsson Note Added: 0099891
2017-04-25 03:37 Roger Olsson Note Added: 0099892
2017-04-25 03:37 Roger Olsson Status resolved => closed
2017-05-02 22:08 Zeljan Rikalo Note Added: 0100068
2017-05-02 22:08 Zeljan Rikalo Status closed => assigned
2017-05-02 22:08 Zeljan Rikalo Resolution fixed => reopened
2017-05-02 22:09 Zeljan Rikalo Fixed in Revision 54696,54697,54707 => 54696,54697,54707,54802
2017-05-02 22:09 Zeljan Rikalo LazTarget - => 1.8
2017-05-02 22:09 Zeljan Rikalo Note Added: 0100069
2017-05-02 22:09 Zeljan Rikalo Status assigned => resolved
2017-05-02 22:09 Zeljan Rikalo Fixed in Version => 1.9 (SVN)
2017-05-02 22:09 Zeljan Rikalo Resolution reopened => fixed
2017-05-02 22:09 Zeljan Rikalo Target Version => 1.8
2017-05-02 22:09 Zeljan Rikalo Status resolved => closed