View Issue Details

IDProjectCategoryView StatusLast Update
0031762LazarusIDEpublic2017-05-11 13:10
ReporterCudaText man Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformgtk2 
Product Version1.9 (SVN) 
Summary0031762: Null size window in IDE
DescriptionAfter i added 2 packages (from avail list to installed list),
*Print* (2 packages for print), I saw this null dlg.

After hour, removed 2 packages.
Again this null size dlg.
(My resize not saved)
TagsNo tags attached.
Fixed in Revision54843, 54844
LazTarget-
Widgetset
Attached Files

Relationships

related to 0031765 closedOndrej Pokorny DBGrid control dislays only one row of data 
related to 0031715 closedOndrej Pokorny high dpi: controls in frame not scaled properly 

Activities

CudaText man

2017-05-07 22:42

reporter  

rebuild-after-pkg.png (43,003 bytes)   
rebuild-after-pkg.png (43,003 bytes)   

wp

2017-05-08 09:11

developer   ~0100151

Last edited: 2017-05-08 10:20

View 2 revisions

Cannot confirm (Win10-64 bit, Laz trunk 32bit):
Printer4Lazarus and Printer4LazIDE already installed by default.
Uninstalled --> Dialog "Confirm new package set for the IDE" has correct height.
Installed again --> Dialog "Confirm new package set for the IDE" has correct height.

Because the height of this dialog seems to depend on the number of already-installed packages: Are there any packages installed in your Lazarus?

CudaText man

2017-05-08 10:09

reporter   ~0100152

@wp,
yes, I have ATsynedit, Python for Lazarus.

Michl

2017-05-08 21:45

developer   ~0100166

I can confirm this issue too on 120dpi Windows 7. Simple try to install any package and click to rebuild IDE. It comes with r54816.

Ondrej Pokorny

2017-05-08 23:43

developer   ~0100171

Thanks for testing and reporting. Fixed.

Issue History

Date Modified Username Field Change
2017-05-07 22:41 CudaText man New Issue
2017-05-07 22:42 CudaText man File Added: rebuild-after-pkg.png
2017-05-08 09:11 wp Note Added: 0100151
2017-05-08 10:09 CudaText man Note Added: 0100152
2017-05-08 10:20 wp Note Edited: 0100151 View Revisions
2017-05-08 21:45 Michl Note Added: 0100166
2017-05-08 21:45 Michl Assigned To => Ondrej Pokorny
2017-05-08 21:45 Michl Status new => assigned
2017-05-08 21:46 Michl Relationship added related to 0031765
2017-05-08 21:46 Michl Relationship added related to 0031715
2017-05-08 23:43 Ondrej Pokorny Fixed in Revision => 54843
2017-05-08 23:43 Ondrej Pokorny LazTarget => -
2017-05-08 23:43 Ondrej Pokorny Note Added: 0100171
2017-05-08 23:43 Ondrej Pokorny Status assigned => resolved
2017-05-08 23:43 Ondrej Pokorny Resolution open => fixed
2017-05-09 09:30 Ondrej Pokorny Fixed in Revision 54843 => 54843, 54844
2017-05-11 13:10 CudaText man Status resolved => closed