View Issue Details

IDProjectCategoryView StatusLast Update
0031765LazarusLCLpublic2017-10-16 12:50
ReporterTsvetoslav Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux OSQ4OS 
Product Version1.9 (SVN) 
Summary0031765: DBGrid control dislays only one row of data
DescriptionThe DBGrid control displays a single row of data, even if the linked data set contains multiple records.
Found on Linux Linux x86_64 (Q4OS 1.8) with current fpc 3.0.2 and Lazarus from trunk.
 
Steps To ReproduceCreate a new GUI application and add a DBGrid and a Button controls, a DataSource and a MemDataset components. Link the DBGrid to the DataSource and and the DataSource to the MemDataset. Add 2-3 columns to the MemDataset, and in Button's OnClick event add code to append a few records to the dataset. Compile, run and press the button. Only one row is dipalyed on the grid.
TagsNo tags attached.
Fixed in Revision54842
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0031715 closedOndrej Pokorny high dpi: controls in frame not scaled properly 
related to 0031762 closedOndrej Pokorny Null size window in IDE 

Activities

Tsvetoslav

2017-05-08 10:24

reporter  

Lazarus_Design2.png (91,472 bytes)   
Lazarus_Design2.png (91,472 bytes)   

Tsvetoslav

2017-05-08 10:25

reporter  

Lazarus_RunTime2.png (16,769 bytes)   
Lazarus_RunTime2.png (16,769 bytes)   

wp

2017-05-08 11:47

developer   ~0100153

Please attach a compilable project which shows the error (only pas, lfm, lpi, lpr files, plus database file unless created on the fly, all packed into a common zip)

Tsvetoslav

2017-05-08 13:56

reporter  

DbGridIssue.zip (2,421 bytes)

Tsvetoslav

2017-05-08 13:57

reporter   ~0100155

I've attached a sample project (DbGridIssue.zip).

wp

2017-05-08 17:02

developer   ~0100156

I checked your demo on Linux Mint 17.1 with Laz trunk (r52799) and an outdated fpc 2.6.4 (gtk2 and qt), as well as on Win10 with Laz trunk (r54762) and fpc 3.02, all 32 bit. None of them show the bug.

Is the issue related to your usage of fpc 3.02, or to 64bit? Or was it only introduced in a recent Laz revision? If yes, can you find out the faulty Laz svn revision?

Paweł Dmitruk

2017-05-08 19:53

reporter   ~0100160

Error in revision 54816

Zeljan Rikalo

2017-05-08 21:05

developer   ~0100162

Assigned to Ondrej since he is commiter of r54816 - this is regression

Ondrej Pokorny

2017-05-08 23:37

developer   ~0100170

Thanks for testing and reporting! Fixed.

Tsvetoslav

2017-10-16 12:50

reporter   ~0103463

Seems OK now.

Issue History

Date Modified Username Field Change
2017-05-08 10:24 Tsvetoslav New Issue
2017-05-08 10:24 Tsvetoslav File Added: Lazarus_Design2.png
2017-05-08 10:25 Tsvetoslav File Added: Lazarus_RunTime2.png
2017-05-08 11:47 wp Note Added: 0100153
2017-05-08 13:56 Tsvetoslav File Added: DbGridIssue.zip
2017-05-08 13:57 Tsvetoslav Note Added: 0100155
2017-05-08 17:02 wp Note Added: 0100156
2017-05-08 19:53 Paweł Dmitruk Note Added: 0100160
2017-05-08 21:05 Zeljan Rikalo LazTarget => -
2017-05-08 21:05 Zeljan Rikalo Note Added: 0100162
2017-05-08 21:05 Zeljan Rikalo Assigned To => Ondrej Pokorny
2017-05-08 21:05 Zeljan Rikalo Status new => assigned
2017-05-08 21:46 Michl Relationship added related to 0031762
2017-05-08 21:47 Michl Relationship added related to 0031715
2017-05-08 23:37 Ondrej Pokorny Fixed in Revision => 54842
2017-05-08 23:37 Ondrej Pokorny Note Added: 0100170
2017-05-08 23:37 Ondrej Pokorny Status assigned => resolved
2017-05-08 23:37 Ondrej Pokorny Resolution open => fixed
2017-10-16 12:50 Tsvetoslav Note Added: 0103463
2017-10-16 12:50 Tsvetoslav Status resolved => closed