View Issue Details

IDProjectCategoryView StatusLast Update
0031788LazarusWidgetsetpublic2017-05-14 18:47
ReporterBart BroersmaAssigned ToBart Broersma 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Buildr54742 
Target Version1.8Fixed in Version1.8 
Summary0031788: Cannot compile for WinCE: error in LazUtf8
DescriptionTrying to build an "empty" LCL application (one form with nothing on it) for WinCE results in:

Compile package FCL 1.0.1: Succes!
Compile package LazUtils 1.0: Exit code 1, Errors: 4, Hints: 4
winlazutf8.inc(230,6) Error: Identifier not found "GetEnvironmentStringsW"
winlazutf8.inc(238,3) Error: Identifier not found "FreeEnvironmentStringsW"
winlazutf8.inc(246,6) Error: Identifier not found "GetEnvironmentStringsW"
winlazutf8.inc(256,3) Error: Identifier not found "FreeEnvironmentStringsW"
Additional InformationFor win32 thes functions reside in Windows unit (unifunc.inc):
function GetEnvironmentStringsW:LPWSTR; external 'kernel32' name 'GetEnvironmentStringsW';function FreeEnvironmentStringsW(_para1:LPWSTR):WINBOOL; external 'kernel32' name 'FreeEnvironmentStringsW';
function GetEnvironmentStringsW:LPWSTR; external 'kernel32' name 'GetEnvironmentStringsW';function FreeEnvironmentStringsW(_para1:LPWSTR):WINBOOL; external 'kernel32' name 'FreeEnvironmentStringsW';

They seem not to be present in WinCE.
TagsNo tags attached.
Fixed in Revisionr54845
LazTarget-
WidgetsetWinCE
Attached Files

Activities

Bart Broersma

2017-05-09 20:02

developer   ~0100183

Severity to block, since we cannot release 1.8 if this is not fixed.

Bart Broersma

2017-05-09 21:08

developer   ~0100185

Introduced in revision 54269 by Mattias: "lazutf8: under Windows use W function for GetEnvironmentStringUTF8 and GetEnvironmentVariable"

Issue History

Date Modified Username Field Change
2017-05-09 20:01 Bart Broersma New Issue
2017-05-09 20:02 Bart Broersma Note Added: 0100183
2017-05-09 20:02 Bart Broersma Severity minor => block
2017-05-09 21:08 Bart Broersma Note Added: 0100185
2017-05-09 21:22 Bart Broersma Fixed in Revision => r54845
2017-05-09 21:22 Bart Broersma Status new => resolved
2017-05-09 21:22 Bart Broersma Fixed in Version => 1.8
2017-05-09 21:22 Bart Broersma Resolution open => fixed
2017-05-09 21:22 Bart Broersma Assigned To => Bart Broersma
2017-05-14 18:47 Bart Broersma Status resolved => closed