View Issue Details

IDProjectCategoryView StatusLast Update
0031811LazarusIDEpublic2017-08-25 10:18
ReporterOndrej Pokorny Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN) 
Summary0031811: Designer changes ActiveControl of designed form automatically if TCustomAbstractGroupedEdit is ActiveControl
DescriptionWhen designing a form in the IDE that has ActiveControl property set to a TCustomAbstractGroupedEdit descendant, the ActiveControl property gets emptied.
Steps To Reproduce1.) Open /trunk/ide/editorfilemanager.lfm
2.) Set ActiveControl to FilterEdit.
3.) Save and close the dialog.
4.) Open it again.
5.) Resize the dialog.
6.) Save and close the dialog.
7.) Open it again.

-> ActiveControl is nil!
Additional InformationIt's due to wrong TabStop mechanism within TCustomAbstractGroupedEdit. Particularly the "TCustomAbstractGroupedEdit.DoEnter" implementation code is wrong.
TagsNo tags attached.
Fixed in Revision54926
LazTarget-
Widgetset
Attached Files

Relationships

related to 0031229 resolvedOndrej Pokorny OI sometimes selects a control as ActiveControl if no ActiveControl is specified in LFM (TimeEdit: ActiveControl not applied) 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-05-14 15:13 Ondrej Pokorny New Issue
2017-05-14 15:15 Ondrej Pokorny Fixed in Revision => 54926
2017-05-14 15:15 Ondrej Pokorny Status new => resolved
2017-05-14 15:15 Ondrej Pokorny Resolution open => fixed
2017-05-14 15:15 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-05-14 16:30 Ondrej Pokorny Relationship added related to 0031773
2017-05-14 16:30 Ondrej Pokorny Relationship deleted related to 0031773
2017-05-14 17:20 Juha Manninen Relationship added related to 0031229
2017-08-25 10:18 Ondrej Pokorny Status resolved => closed