View Issue Details

IDProjectCategoryView StatusLast Update
0031812LazarusIDEpublic2017-05-14 21:52
Reporterbald zhang Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformwindowsOSWindows 
Product Version1.9 (SVN) 
Summary0031812: high dpi: non-visual components are not scaled at design-time
Descriptionnew and exists project, in form designer,
non-visual components are not scaled, both position and size
TagsNo tags attached.
Fixed in Revision54932
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

bald zhang

2017-05-14 17:27

reporter  

bald zhang

2017-05-14 17:27

reporter  

Ondrej Pokorny

2017-05-14 19:47

developer   ~0100309

I cannot reproduce. Please upload a test project.

bald zhang

2017-05-14 20:11

reporter  

container-not-scaled.zip (259,956 bytes)

bald zhang

2017-05-14 20:13

reporter   ~0100310

just open unit1 in ide by the trunk version.
already checked the Tools->Options, looks like nothing related.

Ondrej Pokorny

2017-05-14 20:24

developer   ~0100311

Aaaaahhhh, now I understand what you mean - you mean *non-visual* and not non-visible :)

bald zhang

2017-05-14 21:52

reporter   ~0100312

it's ok now :P

Issue History

Date Modified Username Field Change
2017-05-14 17:27 bald zhang New Issue
2017-05-14 17:27 bald zhang File Added: non-visible-comp-container-bad.png
2017-05-14 17:27 bald zhang File Added: non-visible-comp-container-ok.png
2017-05-14 17:39 Juha Manninen LazTarget => -
2017-05-14 17:39 Juha Manninen Summary high dpi: non-visible component container not saled at design-time => high dpi: non-visible component container not scaled at design-time
2017-05-14 17:57 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-05-14 17:57 Ondrej Pokorny Status new => assigned
2017-05-14 19:47 Ondrej Pokorny Note Added: 0100309
2017-05-14 19:47 Ondrej Pokorny Status assigned => feedback
2017-05-14 20:11 bald zhang File Added: container-not-scaled.zip
2017-05-14 20:13 bald zhang Note Added: 0100310
2017-05-14 20:13 bald zhang Status feedback => assigned
2017-05-14 20:24 Ondrej Pokorny Note Added: 0100311
2017-05-14 20:24 Ondrej Pokorny Summary high dpi: non-visible component container not scaled at design-time => high dpi: non-visual components are not scaled at design-time
2017-05-14 20:24 Ondrej Pokorny Description Updated View Revisions
2017-05-14 21:42 Ondrej Pokorny Fixed in Revision => 54932
2017-05-14 21:42 Ondrej Pokorny Status assigned => resolved
2017-05-14 21:42 Ondrej Pokorny Resolution open => fixed
2017-05-14 21:52 bald zhang Note Added: 0100312
2017-05-14 21:52 bald zhang Status resolved => closed