View Issue Details

IDProjectCategoryView StatusLast Update
0031820LazarusLCLpublic2020-04-12 23:22
ReporterAndrey Korol Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionsuspended 
Platformi386-win32OSWindows 
Product Version1.6.4 
Summary0031820: TDBEdit.Modified property don't reset after DataSet.Post
DescriptionProperty TDBEdit.Modified don't set to false after post changes to dataset.
Perhaps it's worth adding something like:

procedure TDBEdit.UpdateData(Sender: TObject);
begin
  ValidateEdit;
  FDataLink.Field.Text := Text;
  Modified := False; //add
end;
TagsNo tags attached.
Fixed in Revisionr56034
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0036164 resolvedJuha Manninen TDBEdit.Modified is not setting 

Activities

Juha Manninen

2017-10-09 19:10

developer   ~0103300

What about other DB aware controls than TDBEdit?
I also wonder how this kind of error was not noticed earlier? Could others please confirm.
I don't do DB programming myself but I can apply patches if they are otherwise ignored.

Soner

2017-10-11 19:21

reporter   ~0103362

Nobody uses TDBEdit or other datacontrol to check if a field changed, because you can connect a same dataset or same field with many data controls.
I think TField needs a Modified property.

You can take his code without side effects.

Juha Manninen

2017-10-11 23:22

developer   ~0103369

I applied the change. Thanks.

Juha Manninen

2019-12-05 19:34

developer   ~0119637

I forgot to ask the obvious question last time: Why was it important to reset TDBEdit.Modified while it is not useful for testing changed data?
Apparently it is used sometimes. Please see the related issue for details.
I plan to revert the change. We would need a solution to reset TDBEdit.Modified only after DataSet.Post instead of after every change.

Juha Manninen

2020-03-16 21:01

developer   ~0121631

I reverted r56034 in r62769. See the related issue for details.
Please explain why resetting the Modified flag was needed. What about implementing TField.Modified ?

Juha Manninen

2020-04-12 23:22

developer   ~0122101

I resolve as "suspended". Please reopen when you want.

Issue History

Date Modified Username Field Change
2017-05-16 08:35 Andrey Korol New Issue
2017-10-09 17:52 Juha Manninen Assigned To => Juha Manninen
2017-10-09 17:52 Juha Manninen Status new => assigned
2017-10-09 19:10 Juha Manninen LazTarget => -
2017-10-09 19:10 Juha Manninen Note Added: 0103300
2017-10-09 19:10 Juha Manninen Status assigned => feedback
2017-10-11 19:21 Soner Note Added: 0103362
2017-10-11 23:22 Juha Manninen Fixed in Revision => r56034
2017-10-11 23:22 Juha Manninen Note Added: 0103369
2017-10-11 23:22 Juha Manninen Status feedback => resolved
2017-10-11 23:22 Juha Manninen Resolution open => fixed
2019-12-04 23:49 Juha Manninen Relationship added related to 0036164
2019-12-05 19:34 Juha Manninen Status resolved => assigned
2019-12-05 19:34 Juha Manninen Resolution fixed => reopened
2019-12-05 19:34 Juha Manninen Note Added: 0119637
2020-03-16 21:01 Juha Manninen Status assigned => feedback
2020-03-16 21:01 Juha Manninen Note Added: 0121631
2020-04-12 23:22 Juha Manninen Status feedback => resolved
2020-04-12 23:22 Juha Manninen Resolution reopened => suspended
2020-04-12 23:22 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-04-12 23:22 Juha Manninen Note Added: 0122101