View Issue Details

IDProjectCategoryView StatusLast Update
0031890LazarusIDEpublic2017-05-25 20:34
ReporterCudaText man Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUbuntu 14 
Product Version1.9 (SVN) 
Summary0031890: Issues with "Toolbar Config" dialog
Descriptionissues

a) in Toolbar Config window, for 2nd toolbar on coolbar. I deleted last empty-str item; aded item "run w/out debgging" from left side. For new item "run w/o debug" I wanted to move it upper - UI dont allow to move it. Btns "up"/"down" disabled for this item. Picture shows disabled both buttons.

b) pressed OK, entered this dlg again. Now I cannot move+delete last empty-str item.
TagsNo tags attached.
Fixed in Revisionr55042, r55078
LazTarget-
Widgetset
Attached Files

Relationships

related to 0031549 closedJuha Manninen [Patch] ToolbarConfig enhancements 

Activities

CudaText man

2017-05-22 08:06

reporter  

toolbar-cf.png (49,416 bytes)   
toolbar-cf.png (49,416 bytes)   

FTurtle

2017-05-22 09:18

reporter   ~0100577

Last edited: 2017-05-22 09:20

View 2 revisions

The last empty item should not be available for deletion. In Windows I could not reproduce it. Could you tell steps for reliable reproduction of its deletion?
Perhaps this referred with using of filter.

CudaText man

2017-05-22 09:30

reporter   ~0100579

- dialog ToolbarConfig appears
- in left filter edit type "run"
- select "run w/o debug"
- press "arrow right"
- delete empty item

FTurtle

2017-05-22 10:19

reporter   ~0100583

About b):
last item was introduced for make possible insert new item after last. Any operation with it are prohibited. It may be only selected for marking place for inserting new item.

Which revision do you use?
On 55036 I cant delete last item with you instructions (button is disabled).

CudaText man

2017-05-22 10:48

reporter   ~0100586

I use r55040.

Juha Manninen

2017-05-22 10:59

developer   ~0100588

Last edited: 2017-05-22 11:08

View 3 revisions

I can reproduce it with Linux + GTK2.
When nothing is selected in the right side list then a new item is added to the very end, after the empty space.
The events are somehow different. With other widgetsets the last empty item is selected automatically.
With QT the lightning image shows also at the last empty item which is another bug.

FTurtle, if you want to fix and improve it, I have another suggestion:
Delete-key should work the same as the left arrow works now. For a separator the arrow is not logical. A separator is not really moved anywhere.
For other items the delete-key is also intuitive because the items are deleted from that list.

FTurtle

2017-05-22 11:24

reporter   ~0100590

OK, I will see with other widgetsets.

Juha Manninen

2017-05-22 11:52

developer   ~0100593

Last edited: 2017-05-22 12:17

View 3 revisions

Why is the control TListView instead of TListBox? I have no idea.
TListView is a problematic control. Already now the config dialog code has widgetset specific workarounds which is not good.
I think it should be changed to TListBox.

TToolBarConfig.lvToolbarDrawItem is called only with QT. I don't know why.

I fixed the image issue with QT in r55042. The original issue reported by AlexeyT still remains.

Juha Manninen

2017-05-25 13:57

developer   ~0100672

Fixed, please test.

FTurtle

2017-05-25 20:34

reporter   ~0100681

The main cause of the bug is that in some widgetsets setting of lvToolbar.ItemIndex ignores if form is not visible. So, the solution is something like:

procedure TToolBarConfig.FormShow(Sender: TObject);
begin
  lvToolbar.ItemIndex:=lvToolbar.Items.Count-1;
end;

Or:

procedure TToolBarConfig.FormShow(Sender: TObject);
begin
  lvToolbar.Selected := lvToolbar.Items[lvToolbar.Items.Count-1];
end;

I dont see FormShow in your solution.
I will can test something only at Sunday (maybe at Saturday) so I cant say more about your solution right now, but in any case I think that line in wiki should be moved to "Submitted by developer / committer and waiting for testing (do not commit yet)"

Issue History

Date Modified Username Field Change
2017-05-22 08:06 CudaText man New Issue
2017-05-22 08:06 CudaText man File Added: toolbar-cf.png
2017-05-22 09:18 FTurtle Note Added: 0100577
2017-05-22 09:20 FTurtle Note Edited: 0100577 View Revisions
2017-05-22 09:30 CudaText man Note Added: 0100579
2017-05-22 10:19 FTurtle Note Added: 0100583
2017-05-22 10:43 Juha Manninen Relationship added related to 0031549
2017-05-22 10:48 CudaText man Note Added: 0100586
2017-05-22 10:51 Juha Manninen Assigned To => Juha Manninen
2017-05-22 10:51 Juha Manninen Status new => assigned
2017-05-22 10:59 Juha Manninen Note Added: 0100588
2017-05-22 10:59 Juha Manninen Note Edited: 0100588 View Revisions
2017-05-22 11:08 Juha Manninen Note Edited: 0100588 View Revisions
2017-05-22 11:24 FTurtle Note Added: 0100590
2017-05-22 11:52 Juha Manninen Note Added: 0100593
2017-05-22 12:11 Juha Manninen Note Edited: 0100593 View Revisions
2017-05-22 12:17 Juha Manninen Note Edited: 0100593 View Revisions
2017-05-25 13:57 Juha Manninen Fixed in Revision => r55042, r55078
2017-05-25 13:57 Juha Manninen LazTarget => -
2017-05-25 13:57 Juha Manninen Note Added: 0100672
2017-05-25 13:57 Juha Manninen Status assigned => resolved
2017-05-25 13:57 Juha Manninen Resolution open => fixed
2017-05-25 20:34 FTurtle Note Added: 0100681