View Issue Details

IDProjectCategoryView StatusLast Update
0031891LazarusIDEpublic2017-06-06 07:42
ReporterLagunov Aleksey Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN) 
Summary0031891: After rev. 55025 not work manula enter values for property with values list (paPickList in EditorAttributes)
Descriptionwork only select for dropdown combobox

With a large number of elements, it is faster to write the value manually than to select it from the list.

Example - when editing TZStoredProc.StoredProcName (ZEOSDBO) - in the database more than 1000 procedures. Finding them on the list is very inconvenient.

It is necessary to return line 1866 from revision 55025 to a higher state:

Replace:

  ValueComboBox.Style:=csOwnerDrawFixed;

to
 
  ValueComboBox.Style:=csDropDown;
TagsNo tags attached.
Fixed in Revision55242, 55248
LazTarget-
Widgetset
Attached Files

Activities

Ondrej Pokorny

2017-05-22 09:17

developer   ~0100576

What OS/WS?

This seems to be a LCL problem. csOwnerDrawFixed has an edit box on Windows (which shouldn't be there according to Delphi documentation.) See image.

Ondrej Pokorny

2017-05-22 09:18

developer  

OI-Windows.png (24,051 bytes)   
OI-Windows.png (24,051 bytes)   

Lagunov Aleksey

2017-05-22 09:24

reporter   ~0100578

Last edited: 2017-05-22 09:30

View 2 revisions

Lazarus 1.9.0 r55036M FPC 3.1.1 x86_64-linux-gtk2

Fedora 25
Gnome 3.22.2

Lagunov Aleksey

2017-05-22 09:29

reporter  

Ondrej Pokorny

2017-06-05 21:50

developer   ~0100886

Please retest. As a plus, you now can type into customdrawn comboboxes (e.g. for TColor) as well.

Issue History

Date Modified Username Field Change
2017-05-22 08:31 Lagunov Aleksey New Issue
2017-05-22 08:50 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-05-22 08:50 Ondrej Pokorny Status new => assigned
2017-05-22 09:17 Ondrej Pokorny Note Added: 0100576
2017-05-22 09:18 Ondrej Pokorny File Added: OI-Windows.png
2017-05-22 09:24 Lagunov Aleksey Note Added: 0100578
2017-05-22 09:29 Lagunov Aleksey File Added: Снимок экрана от 2017-05-22 10-21-47.png
2017-05-22 09:30 Lagunov Aleksey Note Edited: 0100578 View Revisions
2017-06-05 21:50 Ondrej Pokorny Fixed in Revision => 55242, 55248
2017-06-05 21:50 Ondrej Pokorny LazTarget => -
2017-06-05 21:50 Ondrej Pokorny Note Added: 0100886
2017-06-05 21:50 Ondrej Pokorny Status assigned => resolved
2017-06-05 21:50 Ondrej Pokorny Resolution open => fixed
2017-06-06 07:42 Lagunov Aleksey Status resolved => closed