View Issue Details

IDProjectCategoryView StatusLast Update
0031942LazarusLCLpublic2017-06-08 18:06
Reportercordylus Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSWindows 
Product Version1.6.4 
Summary0031942: TCustomGrid.ScrollToCell may go into infinite loop (still? again?)
DescriptionEssentially 0018660 has to be reopened.

To reproduce, take the attachment from that bug
https://bugs.freepascal.org/file_download.php?file_id=13218&type=bug
And add "Width := 0;" (or any other number less than the scrollbar width, in my case it hangs with values from 0 to 16) before setting ColWidths.
TagsNo tags attached.
Fixed in Revision55267
LazTarget-
Widgetset
Attached Files

Relationships

related to 0018660 closedJesus Reyes TCustomGrid.ScrollToCell may go into infite loop 

Activities

Juha Manninen

2017-06-01 11:23

developer   ~0100769

Please test also with Lazarus trunk or 1.8RC1.

Ondrej Pokorny

2017-06-02 08:55

developer   ~0100791

Last edited: 2017-06-02 08:56

View 2 revisions

I cannot reproduce with trunk. Feel free to reopen if you test trunk or 1.8 and the bug persists there. Upload a test project that I don't have to modify in this case.

There won't be any fixes for 1.6.4 any more.

cordylus

2017-06-02 11:40

reporter   ~0100793

OK, I've built Lazarus from trunk. Indeed, the bug doesn't reproduce anymore on this example. It's a pity since it still reproduces in a complex application. I'll try to create another example, but I'm not sure if I'll succeed at it.

cordylus

2017-06-02 14:19

reporter  

cordylus

2017-06-02 14:24

reporter   ~0100795

Done. Please check out the new test case.

Ondrej Pokorny

2017-06-08 16:49

developer   ~0100947

Please retest.

cordylus

2017-06-08 18:05

reporter   ~0100948

It doesn't hang anymore. Thank you!

Issue History

Date Modified Username Field Change
2017-06-01 08:09 cordylus New Issue
2017-06-01 11:21 Juha Manninen Relationship added related to 0018660
2017-06-01 11:22 Juha Manninen Project Packages => Lazarus
2017-06-01 11:23 Juha Manninen Note Added: 0100769
2017-06-01 11:32 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-06-01 11:32 Ondrej Pokorny Status new => assigned
2017-06-02 08:55 Ondrej Pokorny LazTarget => -
2017-06-02 08:55 Ondrej Pokorny Note Added: 0100791
2017-06-02 08:55 Ondrej Pokorny Status assigned => resolved
2017-06-02 08:55 Ondrej Pokorny Resolution open => fixed
2017-06-02 08:56 Ondrej Pokorny Note Edited: 0100791 View Revisions
2017-06-02 11:40 cordylus Note Added: 0100793
2017-06-02 14:19 cordylus Status resolved => assigned
2017-06-02 14:19 cordylus Resolution fixed => reopened
2017-06-02 14:19 cordylus File Added: grid_scrolltocell_hang_2.zip
2017-06-02 14:24 cordylus Note Added: 0100795
2017-06-08 16:49 Ondrej Pokorny Fixed in Revision => 55267
2017-06-08 16:49 Ondrej Pokorny Status assigned => resolved
2017-06-08 16:49 Ondrej Pokorny Resolution reopened => fixed
2017-06-08 16:49 Ondrej Pokorny Note Added: 0100947
2017-06-08 18:05 cordylus Note Added: 0100948