View Issue Details

IDProjectCategoryView StatusLast Update
0032015LazarusInstallerpublic2018-06-09 20:00
ReporterChrisF Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin64OSWindows 
Product Version1.6.4 
Target Version1.10Fixed in Version1.10 
Summary0032015: Installer doesn't install the 'windres.h' file into the FPC binary directory
DescriptionWindres.h is missing with Lazarus 1.6.4 : at least for the win64 version of Lazarus (I've not checked for the win32 version, but it's possibly OK for this one).

This file is necessary for compiling Windows resource files with Windres.exe.

Note: probably related to issue 0029698. The necessary .exe files have been added, but not the concerned header file.
TagsNo tags attached.
Fixed in Revision58186
LazTarget1.10
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0029698 resolvedMartin Friebe installer does not install windres.exe 

Activities

Juha Manninen

2017-06-14 17:27

developer   ~0101122

What about Lazarus 1.8RC2?

ChrisF

2017-06-14 18:13

reporter   ~0101123

After a quick check, same problem with Lazarus 1.8RC2 : Windres.h is still missing in the binary directory of FPC.

Still for the Win64 version, I mean (Win32 version not checked).

ChrisF

2018-05-03 19:24

reporter   ~0108132

The issue is still present with the current version of Lazarus (Lazarus version 1.8.2 -64 bits versions only-).

Is there any problem to add this simple file into the 64 bits versions of the Lazarus releases ?

Martin Friebe

2018-06-08 16:26

manager   ~0108757

Please test (when release candidates become available)
and close if ok

Issue History

Date Modified Username Field Change
2017-06-14 15:02 ChrisF New Issue
2017-06-14 17:27 Juha Manninen Note Added: 0101122
2017-06-14 18:13 ChrisF Note Added: 0101123
2017-10-09 17:34 Juha Manninen Relationship added related to 0029698
2018-05-03 19:24 ChrisF Note Added: 0108132
2018-05-03 20:56 Martin Friebe Assigned To => Martin Friebe
2018-05-03 20:56 Martin Friebe Status new => assigned
2018-06-08 16:26 Martin Friebe Fixed in Revision => 58186
2018-06-08 16:26 Martin Friebe LazTarget => 1.10
2018-06-08 16:26 Martin Friebe Note Added: 0108757
2018-06-08 16:26 Martin Friebe Status assigned => resolved
2018-06-08 16:26 Martin Friebe Fixed in Version => 1.10
2018-06-08 16:26 Martin Friebe Resolution open => fixed
2018-06-08 16:26 Martin Friebe Target Version => 1.10