View Issue Details

IDProjectCategoryView StatusLast Update
0032134PackagesLCLpublic2017-07-19 19:16
ReporterDarkShadow44 Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindows 7 
Product Version1.8RC3 
Summary0032134: TDBGrid doesn't hide horizontal Scrollbar
DescriptionSince RC1.8RC3 the TDBGrid doesn't hide the horizontal Scrollbar, even if Scrollbars is set to ssNone. It used to work in 1.6.4.
Steps To ReproduceDownload the attached demo and click the button.
Additional InformationThe issue also appears with ArchLinux x64 with Qt.
TagsNo tags attached.
Fixed in Revision55539
LazTarget-
WidgetsetWin32/Win64, QT
Attached Files

Activities

DarkShadow44

2017-07-11 00:10

reporter  

test.7z (60,465 bytes)

Ondrej Pokorny

2017-07-18 23:44

developer   ~0101768

Strange. I cannot reproduce. Please retest with current 1.8 fixes branch or trunk or give more information.

I don't see any scrollbars in your example.

DarkShadow44

2017-07-19 00:56

reporter   ~0101772

For some strange reason I can't seem to reproduce it on windows anymore.
When using Arch linux, getting the latest trunk and compiling it, I get the same issue though. But only when compiling with qt, it works for gtk2. Qt5 and gtk3 don't seem to work, so I can't test that.

Ondrej Pokorny

2017-07-19 08:56

developer   ~0101775

I fixed the Qt issue. But for me the VERTICAL scrollbar was visible, not the horizontal. Please retest.

DarkShadow44

2017-07-19 17:36

reporter   ~0101793

This is odd. But I can confirm that revision 55539 fixes the issue.
No idea what went wrong on windows, but since I can't reproduce that either, I consider it fixed.

Issue History

Date Modified Username Field Change
2017-07-11 00:10 DarkShadow44 New Issue
2017-07-11 00:10 DarkShadow44 File Added: test.7z
2017-07-11 01:32 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-07-11 01:32 Ondrej Pokorny Status new => assigned
2017-07-18 23:44 Ondrej Pokorny LazTarget => -
2017-07-18 23:44 Ondrej Pokorny Note Added: 0101768
2017-07-18 23:44 Ondrej Pokorny Status assigned => resolved
2017-07-18 23:44 Ondrej Pokorny Resolution open => fixed
2017-07-18 23:45 Ondrej Pokorny Resolution fixed => unable to reproduce
2017-07-19 00:56 DarkShadow44 Note Added: 0101772
2017-07-19 08:56 Ondrej Pokorny Fixed in Revision => 55539
2017-07-19 08:56 Ondrej Pokorny Note Added: 0101775
2017-07-19 17:36 DarkShadow44 Note Added: 0101793
2017-07-19 19:16 Ondrej Pokorny Widgetset Win32/Win64 => Win32/Win64, QT
2017-07-19 19:16 Ondrej Pokorny Resolution unable to reproduce => fixed