View Issue Details

IDProjectCategoryView StatusLast Update
0032186LazarusIDEpublic2020-08-16 10:25
ReporterHeiko Tietze Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
Product Version1.9 (SVN) 
Summary0032186: Toggle buttons in anchor editor are not responding with Qt5
DescriptionAnchoring an object left side to the right side (third option for left anchoring) is not possible LCL_PLATFORM qt5 but works with gtk2, for instance (haven't tried other).
TagsNo tags attached.
Fixed in Revision55782
LazTarget-
WidgetsetQT5
Attached Files

Relationships

related to 0029572 closedZeljan Rikalo Qt regression: TGraphicControl.OnClick does not work inside TGroupBox 
related to 0037576 assignedZeljan Rikalo With QT5 anchored controls inside a GroupBox are placed wrongly when the GroupBox has no caption 

Activities

Juha Manninen

2017-07-22 16:29

developer   ~0101851

How about QT4? I am testing with it and everything works.
I understood every other button works with QT5. It sounds strange that only one button would misbehave due to a widgetset bug.

Valdas Jankūnas

2017-07-22 17:21

reporter   ~0101852

I can confirm: in Qt5 WS buttons in Anchor dialog don't work, they give only visual feedback to mouse click.

Linux 64-bit; Kubuntu 17.04; Lazarus 1.9 r.55559; Qt5 v.5.7.1

Heiko Tietze

2017-07-22 19:02

reporter   ~0101854

No problem with qt4. I'd suspect other buttons misbehaves as well. Started with qt5 these days so not much experience yet.

Juha Manninen

2017-07-22 20:46

developer   ~0101856

> in Qt5 WS buttons in Anchor dialog don't work, they give only visual feedback to mouse click.

Ok, it is not just one button then.

Valdas Jankūnas

2017-08-25 20:31

reporter   ~0102379

Same plague has Menu Editor.

I found how to activate those buggy buttons:
 - click on desired button,
 - click outside button (neutral area).

Is a focusing involved in this bug?

Zeljan Rikalo

2017-08-26 11:50

developer   ~0102387

1.Maybe LCLQt5 is missing somewhere in lcl.
2.Please create example project with same buttons and same containers, so it is reproduceable without debugging complete lazarus.

Valdas Jankūnas

2017-08-26 14:48

reporter   ~0102393

OK, I've created test project: copied one groupbox from AncorEditor (from Lazarus project).
 In Gtk2 I can pres and un-press buttons easily.
 In Qt5 button "sticks" in Down state and other buttons not reacts to clicks, my previous mentioned "hack" works, and after some play with that "hack" I sometimes can press and un-press same button continuously.

Valdas Jankūnas

2017-08-26 14:49

reporter  

test.zip (66,592 bytes)

Zeljan Rikalo

2017-08-26 15:30

developer   ~0102395

Yep

Zeljan Rikalo

2017-08-26 15:31

developer  

qt5groupbox.diff (534 bytes)   
Index: lcl/interfaces/qt5/qtwidgets.pas
===================================================================
--- lcl/interfaces/qt5/qtwidgets.pas	(revision 55744)
+++ lcl/interfaces/qt5/qtwidgets.pas	(working copy)
@@ -8510,6 +8510,7 @@
         QMouseEvent_destroy(ANewMouseEvent);
       end;
     end;
+    (*
     QEventMouseMove: // issue #29572
     begin
       // APos :=
@@ -8553,6 +8554,7 @@
         QMouseEvent_destroy(ANewMouseEvent);
       end;
     end;
+    *)
     QEventPaint:
       begin
         Result := False;
qt5groupbox.diff (534 bytes)   

Zeljan Rikalo

2017-08-26 15:33

developer   ~0102396

Please test with attached diff. Note that I won't commit this patch yet, since all mouse stuff have to be tested in case of TQtGroupBox and Qt5.

Valdas Jankūnas

2017-08-26 18:15

reporter   ~0102399

With patch applied I tested MenuEditor and AnchorEditor: works as expected. I'l continue use this patch and I will notify if strangeness happens.

Zeljan Rikalo

2017-08-26 19:17

developer   ~0102404

Thanks !

Zeljan Rikalo

2017-08-30 13:00

developer   ~0102517

All TGraphicControl classes inside TGroupBox have to be tested in this case for OnMouseDown, OnMouseUp, OnMouseMove, OnMouseWheel events.

Zeljan Rikalo

2017-09-03 19:51

developer   ~0102618

Please test and close if ok.

Juha Manninen

2020-08-16 10:25

developer   ~0124915

I must reopen this. Please test with the demo app in related 0037576. Tweak the anchors for a while and the anchor editor buttons go haywire.

Issue History

Date Modified Username Field Change
2017-07-22 12:55 Heiko Tietze New Issue
2017-07-22 16:29 Juha Manninen Note Added: 0101851
2017-07-22 17:21 Valdas Jankūnas Note Added: 0101852
2017-07-22 19:02 Heiko Tietze Note Added: 0101854
2017-07-22 20:46 Juha Manninen Note Added: 0101856
2017-08-25 20:31 Valdas Jankūnas Note Added: 0102379
2017-08-26 11:50 Zeljan Rikalo Note Added: 0102387
2017-08-26 11:51 Zeljan Rikalo Assigned To => Zeljan Rikalo
2017-08-26 11:51 Zeljan Rikalo Status new => assigned
2017-08-26 14:48 Valdas Jankūnas Note Added: 0102393
2017-08-26 14:49 Valdas Jankūnas File Added: test.zip
2017-08-26 15:30 Zeljan Rikalo LazTarget => -
2017-08-26 15:30 Zeljan Rikalo Note Added: 0102395
2017-08-26 15:30 Zeljan Rikalo Status assigned => confirmed
2017-08-26 15:31 Zeljan Rikalo File Added: qt5groupbox.diff
2017-08-26 15:33 Zeljan Rikalo Note Added: 0102396
2017-08-26 15:33 Zeljan Rikalo Status confirmed => feedback
2017-08-26 18:15 Valdas Jankūnas Note Added: 0102399
2017-08-26 19:17 Zeljan Rikalo Note Added: 0102404
2017-08-27 19:16 Zeljan Rikalo Relationship added related to 0032346
2017-08-30 13:00 Zeljan Rikalo Note Added: 0102517
2017-09-03 19:35 Zeljan Rikalo Relationship added related to 0029572
2017-09-03 19:49 Zeljan Rikalo Relationship deleted related to 0032346
2017-09-03 19:51 Zeljan Rikalo Fixed in Revision => 55782
2017-09-03 19:51 Zeljan Rikalo Note Added: 0102618
2017-09-03 19:51 Zeljan Rikalo Status feedback => resolved
2017-09-03 19:51 Zeljan Rikalo Resolution open => fixed
2020-08-16 10:15 Juha Manninen Relationship added related to 0037576
2020-08-16 10:25 Juha Manninen Status resolved => assigned
2020-08-16 10:25 Juha Manninen Resolution fixed => open
2020-08-16 10:25 Juha Manninen Build Lazarus 1.9.0 r55559M FPC 3.0.2 => Lazarus 1.9.0 r55559M FPC 3.0.2
2020-08-16 10:25 Juha Manninen Note Added: 0124915