View Issue Details

IDProjectCategoryView StatusLast Update
0032199PackagesPackagespublic2019-06-15 18:53
ReporterAnthony WalterAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Version1.9 (SVN)Product Buildtrunk 
Target VersionFixed in Version 
Summary0032199: Sparta form designer component event and delete problems on gtk2
DescriptionAs of right now the sparta docked form designer is preventing the creation of default events and your cannot deleted controls with keyboard when using the gtk2 widgetset.

I highly suspect these two issues are related to the same bug, so I am filing them together.
Steps To ReproduceOn lazarus with the gtk2 widgetset and sparta form designer installed.

Drop a TButton on the a new form.
Double click the button.
Press the delete key.

Expected behavior:

Lazarus creates a Button1Click method handled associated with Button1.
The button is removed from the form.

Actual behavior:

Nothing happens.

TagsDockedFormDesigner, sparta_dockedformeditor
Fixed in Revision56048, 56053
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0032515 resolvedMichl Lazarus GTK2: TPanel is ActiveControl 
related to 0032582 resolvedMichl Lazarus Sparta docked form editor: move and resize controls using ctrl+arrow keys and shift+arrow keys not works 
related to 0035720 assignedMichl Lazarus First mouse event is lost in new modal form shown from MouseDown event 

Activities

Anthony Walter

2017-07-25 06:57

reporter   ~0101887

Last edited: 2017-07-25 09:51

View 2 revisions

Note deleted.

Juha Manninen

2017-09-27 10:53

developer   ~0103087

Yes I can reproduce. I wonder why there are so many widgetset dependent bugs. The code should not depend on widgetsets.

Michl

2017-10-07 10:00

developer   ~0103226

It's not a problem of package but GTK2 mouse events.

In TDesigner.MouseDownOnControl the return of GetMouseMsgShift(TheMessage,Shift,Button) in GTK2 there never is ssDouble if Shift (like in Win32).

Wired, if I test a normal program, there in MouseUp ssDouble is in Shift. Maybe Ondrej know, what the problem is (the last big changes were done in revisions 51571, 51723, 51725, 51726). If not, I'll try to find a solution.

Juha Manninen

2017-10-07 13:24

developer   ~0103232

Delete key is not working either. The double-click issue does not explain that.

Michl

2017-10-07 13:37

developer   ~0103233

Last edited: 2017-10-13 16:54

View 3 revisions

I was just wondering why a double click isn't working to create the default event handler. And don't checked the complete issue.

[Edit] Revision 56048 (issue 0032515) fixes the deleting part for me.

Michl

2017-10-14 17:14

developer   ~0103424

I fixed this issue with a workaround. The mouse messages are called for a control (e.g. TButton) and a directed control (TCustomPanel). The LCL accepts just one control for LastMouse. So I don't allow it for the second one.

As far as I could test, it will not break any code (the messages before were also wrong, as for the first control, never a MouseUp is called after MouseDown). But maybe I miss a special case, so I'll not apply it to 1.8 branch.

Anthony Walter

2018-03-02 08:37

reporter   ~0106812

Tested in trunk revision and is fixed. The fix did not make it into lazarus 1.8 :(

Issue History

Date Modified Username Field Change
2017-07-25 01:37 Anthony Walter New Issue
2017-07-25 01:38 Anthony Walter Tag Attached: DockedFormDesigner
2017-07-25 01:38 Anthony Walter Tag Attached: sparta_dockedformeditor
2017-07-25 06:57 Anthony Walter Note Added: 0101887
2017-07-25 09:51 Anthony Walter Note Edited: 0101887 View Revisions
2017-09-27 08:22 Juha Manninen Assigned To => Juha Manninen
2017-09-27 08:22 Juha Manninen Status new => assigned
2017-09-27 10:51 Juha Manninen Assigned To Juha Manninen => Maciej Izak
2017-09-27 10:53 Juha Manninen Note Added: 0103087
2017-10-07 09:36 Michl Assigned To Maciej Izak => Michl
2017-10-07 10:00 Michl Note Added: 0103226
2017-10-07 10:01 Michl Assigned To Michl => Ondrej Pokorny
2017-10-07 13:24 Juha Manninen Note Added: 0103232
2017-10-07 13:37 Michl Note Added: 0103233
2017-10-07 13:39 Michl Note Edited: 0103233 View Revisions
2017-10-07 13:39 Michl Assigned To Ondrej Pokorny => Maciej Izak
2017-10-13 16:54 Michl Note Edited: 0103233 View Revisions
2017-10-13 16:54 Michl Relationship added related to 0032515
2017-10-13 16:54 Michl Assigned To Maciej Izak => Michl
2017-10-13 16:55 Michl Fixed in Revision => 56048
2017-10-13 16:55 Michl LazTarget => -
2017-10-14 17:14 Michl Fixed in Revision 56048 => 56048, 56053
2017-10-14 17:14 Michl Note Added: 0103424
2017-10-14 17:14 Michl Status assigned => resolved
2017-10-14 17:14 Michl Resolution open => fixed
2017-10-20 08:09 Michl Relationship added related to 0032582
2018-03-02 08:37 Anthony Walter Note Added: 0106812
2018-03-02 08:37 Anthony Walter Status resolved => closed
2019-06-15 18:53 Juha Manninen Relationship added related to 0035720