View Issue Details

IDProjectCategoryView StatusLast Update
0032247LazarusIDEpublic2018-01-01 18:23
ReporterMichl Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform64bitOSWindows 
Product Version1.9 (SVN) 
Summary0032247: Packages with doted names: Dotted units events not detected right
DescriptionIf you use a package with dotted names and properties from undotted units (like TNotifyEvent) this works fine. If you want use a event defined in a dotted unit, only the unit name in front of the dot is taken.
Steps To ReproduceTry a component in a dotted unit:

unit dot.foo;
...
type
  TStringEvent = procedure(var UserInfo:String) of object;

  TDotComponent = class(TComponent)
  private
    FOnBar: TNotifyEvent;
    FOnFoo: TStringEvent;
  published
    property OnBar: TNotifyEvent read FOnBar write FOnBar; // this works
    property OnFoo: TStringEvent read FOnFoo write FOnFoo; // this not
  end;

Compilable package added.
- install package in ide
- place a TDotComponent (from DotComponents) on a new form
- in Objectinspector.Events create default event for OnBar -> works fine
- in Objectinspector.Events create default event for OnFoo -> see invalid "dot" in uses clause
Additional InformationFirst reported here: http://www.lazarusforum.de/posting.php?mode=reply&f=19&t=10939
TagsNo tags attached.
Fixed in Revisionr56028
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Michl

2017-08-06 22:12

developer  

DotPackage.zip (2,782 bytes)

Fabio Luis Girardi

2017-08-14 18:21

reporter   ~0102166

Apears to be fixed on Lazarus Trunk, revision 55631.

Michl

2017-08-14 19:26

developer   ~0102167

No. The problem is further visible here: Lazarus 1.9.0 r55664 FPC 3.0.4 i386-win32-win32/win64

Juha Manninen

2017-10-11 16:06

developer   ~0103356

Fixed, please test.

Andi Friess

2017-10-13 06:48

reporter   ~0103394

Works for me
Lazarus 1.9.0 r56035M FPC 3.1.1 i386-win32-win32/win64

THX to Juha

Issue History

Date Modified Username Field Change
2017-08-06 22:12 Michl New Issue
2017-08-06 22:12 Michl File Added: DotPackage.zip
2017-08-08 18:50 Mattias Gaertner Assigned To => Mattias Gaertner
2017-08-08 18:50 Mattias Gaertner Status new => assigned
2017-08-14 18:21 Fabio Luis Girardi Note Added: 0102166
2017-08-14 19:26 Michl Note Added: 0102167
2017-10-11 00:58 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2017-10-11 16:06 Juha Manninen Fixed in Revision => r56028
2017-10-11 16:06 Juha Manninen Note Added: 0103356
2017-10-11 16:06 Juha Manninen Status assigned => resolved
2017-10-11 16:06 Juha Manninen Resolution open => fixed
2017-10-13 06:48 Andi Friess Note Added: 0103394