View Issue Details

IDProjectCategoryView StatusLast Update
0032248LazarusLCLpublic2018-11-07 23:46
ReporterMario BonatiAssigned Towp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu 17.04 64 bitOS VersionUbuntu 17.04 64
Product Version1.9 (SVN)Product BuildLazarus 1.9.0 r55526 FPC 3.0.2 
Target VersionFixed in Version 
Summary0032248: New feature: TPopupNotifier change text color
DescriptionOn my Ubuntu, the TPopupNotifier's default color is yellow, and TPopupNotifier's default text color is white, so text is unreadable.
Color can be changed, but text color no.

When i use it on Ubuntu, i change the color from yellow to black, but I would prefer to be able to change the color of the text.

Thanks in advance, Mario
TagsNo tags attached.
Fixed in Revisionr59486
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Bart Broersma

2017-08-07 15:08

developer   ~0102100

Text/Background color combination should be derived from theme setting, I think.

Mario Bonati

2017-08-08 08:26

reporter   ~0102111

The last time I used this component was about a year ago, and this problem was not there. I do not know if the problem was introduced by Ubuntu or Lazarus.

Hi Mario

M.AUDIO

2017-11-01 14:23

reporter   ~0103842

Would be nice if the foreground color could be just XOR (invert of Background).
choosing clDefault for Background (using TPopupNotifier.Color) does not return the system color for hints but it returns clForm, as I see. lazarus r56243

wp

2018-11-07 23:46

developer   ~0111852

Added new properties TextFont and TitleFont for complete control of text and header fonts.

Please test and close if ok.

Issue History

Date Modified Username Field Change
2017-08-07 10:34 Mario Bonati New Issue
2017-08-07 15:08 Bart Broersma Note Added: 0102100
2017-08-08 08:26 Mario Bonati Note Added: 0102111
2017-11-01 14:23 M.AUDIO Note Added: 0103842
2018-11-07 18:35 wp Assigned To => wp
2018-11-07 18:35 wp Status new => assigned
2018-11-07 23:46 wp Fixed in Revision => r59486
2018-11-07 23:46 wp LazTarget => -
2018-11-07 23:46 wp Note Added: 0111852
2018-11-07 23:46 wp Status assigned => resolved
2018-11-07 23:46 wp Resolution open => fixed