View Issue Details

IDProjectCategoryView StatusLast Update
0032249LazarusLCLpublic2017-11-02 15:54
ReporterJulio Jiménez BorregueroAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu MateOS Version16.04.3
Product Version1.8RC4Product Build 
Target Version1.8RC4Fixed in Version1.9 (SVN) 
Summary0032249: ShowMessage dialog (and related) executed from modal dialog can hide behind the caller form (GTK2)
DescriptionShowMessage, MessageDlg...
If you execute ShowMessage from a modal form, sometimes the message dialog is behind the caller form. If you click on caller form then message dialog is behind it (not in top).
This happens in lazarus 1.8x and lazarus trunk.
All is fine in lazarus 1.6.x.

Only display close button in window title bar.
Steps To ReproduceExecute attached example.
Watch the attached pics.

Check showing dialog message and clicking on form2 to reproduce the pics.
TagsNo tags attached.
Fixed in Revision55848
LazTarget1.8
WidgetsetGTK 2
Attached Files

Relationships

related to 0013051 acknowledgedZeljan Rikalo Wrong window types 
related to 0017848 closedZeljan Rikalo MessageDlg odd positions 
related to 0032575 feedbackJesus Reyes Codetools sets focus to another window (Ctrl + Space) 
related to 0032635 resolvedJesus Reyes Lazarus Dialog modal windows go behind regular windows and won't come on top 

Activities

Julio Jiménez Borreguero

2017-08-07 10:52

reporter  

issuedialogs.zip (128,375 bytes)

Julio Jiménez Borreguero

2017-08-07 10:52

reporter  

issue_laz1_8.png (202,439 bytes)
issue_laz1_8.png (202,439 bytes)

Julio Jiménez Borreguero

2017-08-07 10:53

reporter  

ok_laz_1_6x.png (176,531 bytes)
ok_laz_1_6x.png (176,531 bytes)

Julio Jiménez Borreguero

2017-08-07 11:01

reporter   ~0102098

Last edited: 2017-08-07 12:58

View 4 revisions

Linux QT and windows are ok (like in lazarus 1.6.x)
Free Pascal Compiler version 3.0.3 [2017/06/26] for x86_64

Ubuntu Mate+compton or Mate+compiz (compiz also fails in lazarus 1.6.x)

Linuxmint 18.2 Cinnamon 64bits. lazarus 1.8.x and trunk fail. Lazarus 1.6.x is ok

Ondrej Pokorny

2017-08-07 16:22

developer   ~0102104

Could you please try to bisect the guilty version? Thanks!

Julio Jiménez Borreguero

2017-08-07 17:26

reporter   ~0102106

This version fails (1.8 creation):

URL: https://svn.freepascal.org/svn/lazarus/branches/fixes_1_8
Relative URL: ^/branches/fixes_1_8
Raíz del repositorio: https://svn.freepascal.org/svn/lazarus
UUID del repositorio: 4005530d-fff6-0310-9dd1-cebe43e6787f
Revisión: 54579
Tipo de nodo: directorio
Agendado: normal
Autor del último cambio: mattias
Revisión del último cambio: 54579
Fecha de último cambio: 2017-04-08 23:56:13 +0200 (sáb 08 de abr de 2017)

This version works (but it's fixes 1.6.x)
Working Copy Root Path: /home/jujibo/FreePascal-3.0.3/lazarus-1.6.fixes/lazarus
URL: https://svn.freepascal.org/svn/lazarus/branches/fixes_1_6
Relative URL: ^/branches/fixes_1_6
Raíz del repositorio: https://svn.freepascal.org/svn/lazarus
UUID del repositorio: 4005530d-fff6-0310-9dd1-cebe43e6787f
Revisión: 55629
Tipo de nodo: directorio
Agendado: normal
Autor del último cambio: maxim
Revisión del último cambio: 54551
Fecha de último cambio: 2017-04-07 01:16:45 +0200 (vie 07 de abr de 2017)

I think the problem is inherited from trunk and probably months ago.

I don't see other commits in 1.8 fixes. Is there another branch where to check or must I check in lazarus trunk?

Julio Jiménez Borreguero

2017-08-07 18:23

reporter   ~0102107

Last edited: 2017-08-07 18:33

View 3 revisions

I have found it. As suspected, it comes from lazarus trunk and probably merged to laz 1.8:

Edited:

URL: https://svn.freepascal.org/svn/lazarus/trunk
Relative URL: ^/trunk
Raíz del repositorio: https://svn.freepascal.org/svn/lazarus
UUID del repositorio: 4005530d-fff6-0310-9dd1-cebe43e6787f
Revisión: 54197
Tipo de nodo: directorio
Agendado: normal
Autor del último cambio: ondrej
Revisión del último cambio: 54197
Fecha de último cambio: 2017-02-19 18:37:44 +0100 (dom 19 de feb de 2017)

gtk2: fix window type hints for modal/nonmodal forms. Issue 13051


Prev rev (r54196) is ok.

Julio Jiménez Borreguero

2017-08-07 18:40

reporter   ~0102108

Changes in r54197 also breaks the buttons at window title (only shows close button)

r54196 shows minimize, maximize and close buttons (like QT and Windows)

Julio Jiménez Borreguero

2017-08-07 18:44

reporter   ~0102109

r54196 is ok except for compiz. Using compiz and cicking in form2 shows the issue (hidding message window) but shows all buttons in window (minimize, maximize and close buttons)

Jesus Reyes

2017-09-12 17:50

developer   ~0102807

To translate late ....

falla únicamente con los diálogos del sistema... showmessage, MsgDlg...
<jujibo> con uno tuyo no falla
<jujibo> aunque también desaparecen los botones
<jesusrmx> ah buena pista
<jujibo> y otro detalle es que el form del mensaje.. aunque está detrás de la ventana.. sigue activo.. si pulsas la barra espaciadora se pulsa el botón
<jesusrmx> podría seguir el proceso de ver como se crea un showmessage window y comparar con un formulario normal
<jujibo> jesusrmx: el problema es que han cambiado la identificación de los diálogos
<jesusrmx> sabes que voy a copiar lo que acabas de decir en el reporte
<jujibo> y es algo que no entiendo.. en gtk2 es muy sencillo... padre de la ventana y modo.. no hay más
<jesusrmx> para tenerlo presente sin tener que buscar el texto en el chat
<jujibo> y lo de stayontop...
<jujibo> sin problema :)

Jesus Reyes

2017-09-13 02:26

developer   ~0102816

I have checked linuxmint/mate with and without compiz, xubuntu (where it failed regardless of compiz). Windows with normal border style and dialog style, decoration buttons should be ok in all cases and animations under compiz should be fine too.

Please test.

Julio Jiménez Borreguero

2017-09-13 09:52

reporter   ~0102818

From my side it's fixed. Don't forget merge to 1.8RC4.

Thanks!

Issue History

Date Modified Username Field Change
2017-08-07 10:52 Julio Jiménez Borreguero New Issue
2017-08-07 10:52 Julio Jiménez Borreguero File Added: issuedialogs.zip
2017-08-07 10:52 Julio Jiménez Borreguero File Added: issue_laz1_8.png
2017-08-07 10:53 Julio Jiménez Borreguero File Added: ok_laz_1_6x.png
2017-08-07 11:01 Julio Jiménez Borreguero Note Added: 0102098
2017-08-07 11:19 Julio Jiménez Borreguero Note Edited: 0102098 View Revisions
2017-08-07 12:53 Julio Jiménez Borreguero Note Edited: 0102098 View Revisions
2017-08-07 12:58 Julio Jiménez Borreguero Note Edited: 0102098 View Revisions
2017-08-07 16:22 Ondrej Pokorny Note Added: 0102104
2017-08-07 17:26 Julio Jiménez Borreguero Note Added: 0102106
2017-08-07 18:23 Julio Jiménez Borreguero Note Added: 0102107
2017-08-07 18:24 Julio Jiménez Borreguero Note Edited: 0102107 View Revisions
2017-08-07 18:33 Julio Jiménez Borreguero Note Edited: 0102107 View Revisions
2017-08-07 18:34 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-08-07 18:34 Ondrej Pokorny Status new => assigned
2017-08-07 18:40 Julio Jiménez Borreguero Note Added: 0102108
2017-08-07 18:44 Julio Jiménez Borreguero Note Added: 0102109
2017-08-09 17:18 Jesus Reyes Relationship added related to 0013051
2017-09-12 17:50 Jesus Reyes Note Added: 0102807
2017-09-13 02:19 Jesus Reyes Assigned To Ondrej Pokorny => Jesus Reyes
2017-09-13 02:26 Jesus Reyes Fixed in Revision => 55848
2017-09-13 02:26 Jesus Reyes LazTarget => 1.8
2017-09-13 02:26 Jesus Reyes Note Added: 0102816
2017-09-13 02:26 Jesus Reyes Status assigned => resolved
2017-09-13 02:26 Jesus Reyes Fixed in Version => 1.9 (SVN)
2017-09-13 02:26 Jesus Reyes Resolution open => fixed
2017-09-13 02:26 Jesus Reyes Target Version => 1.8RC4
2017-09-13 02:34 Jesus Reyes Relationship added related to 0017848
2017-09-13 09:52 Julio Jiménez Borreguero Note Added: 0102818
2017-10-21 23:29 Michl Relationship added related to 0032575
2017-11-02 15:54 Juha Manninen Relationship added related to 0032635