View Issue Details

IDProjectCategoryView StatusLast Update
0032275FPCDocumentationpublic2017-08-16 14:34
ReporterRafael PicancoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0032275: Arguments construct is not documented
DescriptionMy suggestion is to create a "System Parameters" entry here:

https://www.freepascal.org/docs-html/ref/refse91.html#x175-19700014.4

Ideally, the Arguments construct should have an hyperlink pointing to the docs.

This would also contribute to the documentation of methods like:
https://www.freepascal.org/docs-html/rtl/system/write.html

For instance, where Arguments is implemented in FPC sources?
Additional InformationFollowing this thread:

https://forum.lazarus.freepascal.org/index.php/topic,36922.15.html
TagsNo tags attached.
Fixed in Revision1418
FPCOldBugId
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2017-08-16 10:57

administrator   ~0102201

The documentation is generated from actual sources. Since Write(Ln) does not exist as an actual declaration in the system unit but is handled as a compiler intrinsic, a dummy declaration is used.

I replaced the "Arguments" with 3 overloaded versions and specified that the actual number is arbitrary. I also clarified what types are accepted.

Rafael Picanco

2017-08-16 14:34

reporter   ~0102204

Thank you for the clarification!

Issue History

Date Modified Username Field Change
2017-08-15 20:47 Rafael Picanco New Issue
2017-08-15 22:30 Bart Broersma Project Lazarus => FPC
2017-08-16 10:57 Michael Van Canneyt Fixed in Revision => 1418
2017-08-16 10:57 Michael Van Canneyt Note Added: 0102201
2017-08-16 10:57 Michael Van Canneyt Status new => resolved
2017-08-16 10:57 Michael Van Canneyt Fixed in Version => 3.1.1
2017-08-16 10:57 Michael Van Canneyt Resolution open => fixed
2017-08-16 10:57 Michael Van Canneyt Assigned To => Michael Van Canneyt
2017-08-16 10:57 Michael Van Canneyt Target Version => 3.2.0
2017-08-16 14:34 Rafael Picanco Note Added: 0102204
2017-08-16 14:34 Rafael Picanco Status resolved => closed