View Issue Details

IDProjectCategoryView StatusLast Update
0032340LazarusIDEpublic2020-10-15 14:06
ReporterBenito van der Zander Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionreopened 
Product Version1.8RC4 
Summary0032340: lazbuild exception
DescriptionI was running lazbuild in gdb and it aborted after compiling a package

(1008) 121248 lines compiled, 7.1 sec
(1021) 45 warning(s) issued
(1022) 207 hint(s) issued
(1023) 28 note(s) issued
An unhandled exception occurred at $0000000000594244:
EObjectCheck: Object reference is Nil
  $0000000000594244
  $00000000005E042A
  $00000000005E58C9
  $00000000005E6EF8


Thread 1 "lazbuild" received signal SIGSEGV, Segmentation fault.
0x00000000009bde64 in UPDATELISTING (this=0x7fffee34d720) at directorycacher.pas:672
672 GetMem(FListing.Files,TotalLen);
(gdb) bt
# 0 0x00000000009bde64 in UPDATELISTING (this=0x7fffee34d720) at directorycacher.pas:672
# 1 0x00000000009bedcd in INDEXOFFILECASESENSITIVE (this=0x7fffee34d720, SHORTFILENAME=0x7fffedf0b5d8 '.fpc.cfg') at directorycacher.pas:868
# 2 0x00000000009bf317 in FINDFILE (this=0x7fffee34d720, SHORTFILENAME=0x7fffedf0b5d8 '.fpc.cfg', FILECASE=CTSFCDEFAULT) at directorycacher.pas:969
# 3 0x00000000009c168c in FILEEXISTS (this=0x7ffff7fd77c0, FILENAME=0x7fffee1ccdd8 '/home/theo/.fpc.cfg') at directorycacher.pas:1570
# 4 0x0000000000963901 in FILEEXISTSCACHED (AFILENAME=0x7fffee1ccdd8 '/home/theo/.fpc.cfg') at lazfilecache.pas:132
# 5 0x0000000000578428 in NEEDSUPDATE (this=0x7fffee3a6dc0) at definetemplates.pas:8754
# 6 0x000000000057b049 in GETDEFAULTCOMPILERTARGET (this=0x7ffff7e22660, COMPILERFILENAME=0x7fffedfaba58 '/usr/local/bin/fpc', COMPILEROPTIONS=0x0, TARGETOS=0x0, TARGETCPU=0x0)
    at definetemplates.pas:9183
# 7 0x00000000005f2f3b in MAKEOPTIONSSTRING (this=0x7fffebff5790, FLAGS=...) at compileroptions.pp:2831
# 8 0x000000000068f3dd in DOCHECKIFPROJECTNEEDSCOMPILATION (this=0x7ffff7fcc540, APROJECT=0x7fffebffffb0, NEEDBUILDALLFLAG=false, NOTE=0x0) at buildmanager.pas:1164
# 9 0x0000000000422239 in STARTBUILDING (parentfp=0x7fffffffd620) at lazbuild.lpr:818
# 10 0x0000000000421ae5 in BUILDPROJECT (this=0x7fffee3a66c0, AFILENAME=0x7ffff7feaeb8 '/home/theo/hg/programs/internet/xidel/xidel.lpi') at lazbuild.lpr:965
# 11 0x000000000041f91a in BUILDFILE (this=0x7fffee3a66c0, FILENAME=0x7ffff7feaeb8 '/home/theo/hg/programs/internet/xidel/xidel.lpi') at lazbuild.lpr:417
# 12 0x00000000004260f0 in RUN (this=0x7fffee3a66c0) at lazbuild.lpr:1467
# 13 0x000000000042905c in main () at lazbuild.lpr:1870






TagsNo tags attached.
Fixed in Revisionr55748, r64005
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0032676 resolvedJuha Manninen lazbuild exception 
related to 0036318 resolvedJuha Manninen lazbuild crashes when compiling packages 

Activities

Juha Manninen

2017-08-26 23:58

developer   ~0102412

Please test with r55748.

Juha Manninen

2017-08-27 17:50

developer   ~0102447

Benito ping...
Does r55748 make any difference?

Benito van der Zander

2017-08-27 18:36

reporter   ~0102448

It has only happened once so far even without the patch...

Juha Manninen

2017-09-10 14:20

developer   ~0102751

This is either fixed or it was a temporary hiccup.
Resolving.

Benito van der Zander

2017-11-12 18:08

reporter   ~0104040

It has happened again:

(9009) Assembling interfaces
/home/theo/opt/lazarus/lcl/interfaces/./nogui/alllclintfunits.pas(6,3) Hint: (5023) Unit "NoGUIInt" not used in AllLCLIntfUnits
/home/theo/opt/lazarus/lcl/interfaces/./nogui/alllclintfunits.pas(7,3) Hint: (5023) Unit "NoGUIWSFactory" not used in AllLCLIntfUnits
(9009) Assembling alllclintfunits
(9009) Assembling lcl
(1008) 726 lines compiled, 0.5 sec
(1022) 20 hint(s) issued
An unhandled exception occurred at $00000000005866D9:
EObjectCheck: Object reference is Nil
  $00000000005866D9
  $00000000005D1896
  $00000000005D6E40
  $00000000005D84D4

An unhandled exception occurred at $00000000009B53B4:
EAccessViolation: Access violation
  $00000000009B53B4
  $00000000009B6370
  $00000000009B6915
  $00000000009B8DDA
  $000000000095A351
  $000000000056B3E4
  $000000000056DF69
  $00000000005E4A67
  $0000000000683A32
  $0000000000422452
  $0000000000421CBC
  $000000000041F9C8
  $000000000042652D
  $000000000042972D

Marked memory at $00007F3C8F625880 invalid
Wrong signature $AAAAAAAA instead of 3B699FE1
  $000000000042972D
  $000000000041E2DD
FAILED!

Juha Manninen

2017-11-12 18:56

developer   ~0104043

You should debug the code yourself. The first backtrace looks useful but sometimes only debugging reveals the actual location of error.
I added an assertion in r56376 but it may not help. According to your BT no references are Nil. They can still be freed and invalid.

Your latest backtrace is not very useful. It only has hex numbers.

Benito van der Zander

2017-12-05 19:57

reporter   ~0104473

Today it crashed on Travis again...

But not again my computer despite not updating and running the lazbuild version that crashed before. It is a very rare occurrence.

Benito van der Zander

2018-03-12 23:40

reporter   ~0107079

I have only seen this happen once since the last comment, this weekend on travis ci again:

Info: (lazarus) Execute Title="Compile package LCL 1.8.0.5"
Info: (lazarus) Working Directory="/usr/share/lazarus/1.8.0RC5/lcl/interfaces/"
Info: (lazarus) Executable="/usr/lib/fpc/3.0.4/ppcross386"
Info: (lazarus) Param[0]="-B"
Info: (lazarus) Param[1]="-Tandroid"
Info: (lazarus) Param[2]="-MObjFPC"
Info: (lazarus) Param[3]="-Scghi"
Info: (lazarus) Param[4]="-O1"
Info: (lazarus) Param[5]="-g"
Info: (lazarus) Param[6]="-gl"
Info: (lazarus) Param[7]="-l"
Info: (lazarus) Param[8]="-vewnhibq"
Info: (lazarus) Param[9]="-vm5044"
Info: (lazarus) Param[10]="-Fi/usr/share/lazarus/1.8.0RC5/lcl/interfaces/nogui"
Info: (lazarus) Param[11]="-Fu/usr/share/lazarus/1.8.0RC5/lcl/interfaces/nogui"
Info: (lazarus) Param[12]="-Fu/home/travis/.lazarus/lib/units/i386-android"
Info: (lazarus) Param[13]="-Fu/home/travis/.lazarus/lib/LazUtils/lib/i386-android"
Info: (lazarus) Param[14]="-Fu/home/travis/.lazarus/lib/LCLBase/units/i386-android"
Info: (lazarus) Param[15]="-Fu/usr/share/lazarus/1.8.0RC5/lcl/interfaces/"
Info: (lazarus) Param[16]="-FU/home/travis/.lazarus/lib/units/i386-android/nogui"
Info: (lazarus) Param[17]="lcl.pas"
Hint: (11030) Start of reading config file /home/travis/.fpc.cfg
Hint: (11030) Start of reading config file /etc/fpc.cfg
Hint: (11031) End of reading config file /etc/fpc.cfg
Hint: (11031) End of reading config file /home/travis/.fpc.cfg
Free Pascal Compiler version 3.0.4rc1 [2018/03/11] for i386
Copyright (c) 1993-2017 by Florian Klaempfl and others
(1002) Target OS: Android for i386
(3104) Compiling lcl.pas
(3104) Compiling ./nogui/alllclintfunits.pas
(3104) Compiling ./nogui/interfaces.pp
(3104) Compiling ./nogui/noguiint.pp
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(39,44) Hint: (5024) Parameter "Sender" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(46,32) Hint: (5024) Parameter "ScreenInfo" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(53,38) Hint: (5024) Parameter "ATitle" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(54,38) Hint: (5024) Parameter "DC" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(54,52) Hint: (5024) Parameter "lpLogFont" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(54,78) Hint: (5024) Parameter "Callback" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(54,109) Hint: (5024) Parameter "Lparam" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(54,130) Hint: (5024) Parameter "Flags" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(60,31) Hint: (5024) Parameter "Interval" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(60,55) Hint: (5024) Parameter "TimerFunc" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(61,32) Hint: (5024) Parameter "TimerHandle" not used
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/noguiint.pp(62,35) Hint: (5024) Parameter "Sender" not used
(3104) Compiling ./nogui/noguiwsfactory.pas
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/interfaces.pp(21,3) Hint: (5023) Unit "InterfaceBase" not used in Interfaces
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/interfaces.pp(26,18) Hint: (5023) Unit "NoGUIWSFactory" not used in Interfaces
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/alllclintfunits.pas(6,3) Hint: (5023) Unit "NoGUIInt" not used in AllLCLIntfUnits
/usr/share/lazarus/1.8.0RC5/lcl/interfaces/./nogui/alllclintfunits.pas(7,3) Hint: (5023) Unit "NoGUIWSFactory" not used in AllLCLIntfUnits
(1008) 726 lines compiled, 0.2 sec
(1022) 20 hint(s) issued
Warning: (lazarus) [TLazPackageGraph.ConvertPackageRSTFiles] skipping read only directory /usr/share/lazarus/1.8.0RC5/lcl/languages/
An unhandled exception occurred at $0000000000000000:
EAccessViolation: Access violation
  $0000000000000000
  $0000000000579F17
  $000000000057B121
TProject.DoLoadStateFile Statefile not found: /home/travis/build/benibela/sf/programs/internet/VideLibri/android/lib/i386-android/.compiled
An unhandled exception occurred at $00000000004EDEF8:
EAccessViolation: Access violation
  $00000000004EDEF8
  $00000000004F3B97
  $00000000009E2840
  $00000000009E1C4C
  $000000000040473F
  $0000000000403C36
  $0000000000401E05
  $00000000004077F5
  $000000000040A48F
FAILED!

Benito van der Zander

2018-07-14 15:55

reporter   ~0109452

An unhandled exception occurred at $0000000000587F9F:
EObjectCheck: Object reference is Nil
  $0000000000587F9F ideexterntoolintf.pas, line 1220. TAbstractExternalTool.LeaveCriticalSection: FWorkerMessages.LeaveCriticalSection
  $00000000005D08F8 exttools.pas, line 590. TExternalTool.SetThread: LeaveCriticalSection;
  $00000000005D4A34 exttools.pas, line 1526. TExternalToolThread.SetTool: FTool.Thread:=nil;
  $00000000005D5C3E exttools.pas, line 1815. TExternalToolThread.Destroy: Tool:=nil;

Juha Manninen

2020-10-15 14:06

developer   ~0126329

Apparently fixed. Please test.

Issue History

Date Modified Username Field Change
2017-08-26 19:54 Benito van der Zander New Issue
2017-08-26 23:58 Juha Manninen Assigned To => Juha Manninen
2017-08-26 23:58 Juha Manninen Status new => assigned
2017-08-26 23:58 Juha Manninen LazTarget => -
2017-08-26 23:58 Juha Manninen Note Added: 0102412
2017-08-26 23:58 Juha Manninen Status assigned => feedback
2017-08-27 17:50 Juha Manninen Note Added: 0102447
2017-08-27 18:36 Benito van der Zander Note Added: 0102448
2017-08-27 18:36 Benito van der Zander Status feedback => assigned
2017-09-10 14:20 Juha Manninen Fixed in Revision => r55748
2017-09-10 14:20 Juha Manninen Note Added: 0102751
2017-09-10 14:20 Juha Manninen Status assigned => resolved
2017-09-10 14:20 Juha Manninen Resolution open => fixed
2017-11-12 18:08 Benito van der Zander Note Added: 0104040
2017-11-12 18:08 Benito van der Zander Status resolved => assigned
2017-11-12 18:08 Benito van der Zander Resolution fixed => reopened
2017-11-12 18:14 Juha Manninen Relationship added has duplicate 0032676
2017-11-12 18:56 Juha Manninen Note Added: 0104043
2017-11-13 11:20 Juha Manninen Assigned To Juha Manninen =>
2017-11-13 11:20 Juha Manninen Status assigned => new
2017-12-05 19:57 Benito van der Zander Note Added: 0104473
2018-03-12 23:40 Benito van der Zander Note Added: 0107079
2018-07-14 15:55 Benito van der Zander Note Added: 0109452
2019-11-16 07:31 Juha Manninen Relationship added related to 0036318
2020-10-15 14:06 Juha Manninen Assigned To => Juha Manninen
2020-10-15 14:06 Juha Manninen Status new => resolved
2020-10-15 14:06 Juha Manninen Fixed in Revision r55748 => r55748, r64005
2020-10-15 14:06 Juha Manninen Widgetset GTK 2 => GTK 2
2020-10-15 14:06 Juha Manninen Note Added: 0126329