View Issue Details

IDProjectCategoryView StatusLast Update
0032354LazarusIDEpublic2017-08-30 12:32
ReporterValdas Jankūnas Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformlinux 4.10.0-33-genericOSKubuntu 17.04 
Product Version1.9 (SVN) 
Summary0032354: [Qt5] In source editor hints are different color and empty
DescriptionIn all parts of IDE (and in entire KDE) except SourceEditor hints are gray text on dark background. In SourceEditor background of hints are gray and they contains no text or maybe text with same color as background (see picture).
Additional InformationQt v5.7.1
TagsNo tags attached.
Fixed in Revision55760
LazTarget-
WidgetsetQT, QT5
Attached Files

Activities

Valdas Jankūnas

2017-08-29 10:09

reporter  

empty_hint.png (27,662 bytes)   
empty_hint.png (27,662 bytes)   

Zeljan Rikalo

2017-08-29 11:54

developer   ~0102493

Kubuntu is 32 or 64 bit ?

Valdas Jankūnas

2017-08-29 12:50

reporter   ~0102495

Last edited: 2017-08-29 12:55

View 3 revisions

It's a 64-bit version.
Tested Widget styles Breeze, Fusion, MS Windows 9x, Oxygen and Qt Curve: hint is always empty.

Zeljan Rikalo

2017-08-29 13:30

developer   ~0102496

Ok, seem that it's related to Qt-5.7.1. I'll install kubuntu into virtual machine and see what can be done.

Zeljan Rikalo

2017-08-29 14:41

developer   ~0102498

Sorry but I cannot reproduce your problem in vmware virtual machine.
Installed Kubuntu 17.04 64 bit, fully updated, trunk lazarus + fpc-3.0.4rc1.
Everything works fine. Please test with fpc 3.0.xx so we are sure that it isn't problem with your kubuntu configuration.

Ondrej Pokorny

2017-08-30 08:09

developer   ~0102504

With or without installed TurboPowerIProDsgn?

Zeljan Rikalo

2017-08-30 08:57

developer   ~0102505

Last edited: 2017-08-30 08:57

View 2 revisions

It's installed, but normal hints works ok too.

Zeljan Rikalo

2017-08-30 11:04

developer   ~0102511

Yes, it's reproducable without TurboPowerIProDsgn installed.

Zeljan Rikalo

2017-08-30 11:05

developer   ~0102512

Information box in OI is ok, only hints text isn't visible.

Zeljan Rikalo

2017-08-30 12:14

developer   ~0102514

Added Qt4 too since it have same bug.

Zeljan Rikalo

2017-08-30 12:20

developer   ~0102515

Please test and close if ok.

Valdas Jankūnas

2017-08-30 12:32

reporter   ~0102516

Thanks!

Issue History

Date Modified Username Field Change
2017-08-29 10:09 Valdas Jankūnas New Issue
2017-08-29 10:09 Valdas Jankūnas File Added: empty_hint.png
2017-08-29 11:51 Zeljan Rikalo Assigned To => Zeljan Rikalo
2017-08-29 11:51 Zeljan Rikalo Status new => assigned
2017-08-29 11:54 Zeljan Rikalo LazTarget => -
2017-08-29 11:54 Zeljan Rikalo Note Added: 0102493
2017-08-29 11:54 Zeljan Rikalo Status assigned => feedback
2017-08-29 12:50 Valdas Jankūnas Note Added: 0102495
2017-08-29 12:50 Valdas Jankūnas Status feedback => assigned
2017-08-29 12:51 Valdas Jankūnas Note Edited: 0102495 View Revisions
2017-08-29 12:55 Valdas Jankūnas Note Edited: 0102495 View Revisions
2017-08-29 13:30 Zeljan Rikalo Note Added: 0102496
2017-08-29 14:41 Zeljan Rikalo Note Added: 0102498
2017-08-29 14:41 Zeljan Rikalo Status assigned => feedback
2017-08-30 08:09 Ondrej Pokorny Note Added: 0102504
2017-08-30 08:57 Zeljan Rikalo Note Added: 0102505
2017-08-30 08:57 Zeljan Rikalo Note Edited: 0102505 View Revisions
2017-08-30 11:04 Zeljan Rikalo Note Added: 0102511
2017-08-30 11:04 Zeljan Rikalo Status feedback => confirmed
2017-08-30 11:05 Zeljan Rikalo Note Added: 0102512
2017-08-30 12:14 Zeljan Rikalo Widgetset QT5 => QT, QT5
2017-08-30 12:14 Zeljan Rikalo Note Added: 0102514
2017-08-30 12:20 Zeljan Rikalo Fixed in Revision => 55760
2017-08-30 12:20 Zeljan Rikalo Note Added: 0102515
2017-08-30 12:20 Zeljan Rikalo Status confirmed => resolved
2017-08-30 12:20 Zeljan Rikalo Resolution open => fixed
2017-08-30 12:32 Valdas Jankūnas Note Added: 0102516
2017-08-30 12:32 Valdas Jankūnas Status resolved => closed