View Issue Details

IDProjectCategoryView StatusLast Update
0032369LazarusOtherpublic2017-09-03 22:12
ReporterMiloŇ° Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
OSall 
Product Version1.8RC3 
Summary0032369: Declare out parameters as out, no var
DescriptionThis is declaration of BlockWrite:
Procedure BlockWrite(var f:File;const Buf;Count:Int64;var Result:Int64);

IMHO, correct declaration is:
Procedure BlockWrite(var f:File;const Buf;Count:Int64;out Result:Int64);

Is any reason for this declaration?
There are more declaration as this in FPC.
Problem of this declaration is this:
mainform.pp(201,54) Hint: Local variable "FindData" does not seem to be initialized

This message is from declaration IShellLinkA.GetPath:
function GetPath(pszFile:LPSTR; cch:longint;var pfd:WIN32_FIND_DATA; fFlags:DWORD):HRESULT;StdCall;

I think that correct is:
function GetPath(pszFile:LPSTR; cch:longint;out pfd:WIN32_FIND_DATA; fFlags:DWORD):HRESULT;StdCall;
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0029946 resolvedMarco van de Voort FPC GetTextExtentPoint32W() declaration 
related to 0031527 new Lazarus var/out winapi parameters: GetCursorPos, GetCaretPos, GetWindowRect 

Activities

Ondrej Pokorny

2017-09-03 22:12

developer   ~0102623

Please close, it's been reported several times already.

Issue History

Date Modified Username Field Change
2017-09-03 17:29 MiloŇ° New Issue
2017-09-03 22:10 Ondrej Pokorny LazTarget => -
2017-09-03 22:10 Ondrej Pokorny Relationship added duplicate of 0029946
2017-09-03 22:10 Ondrej Pokorny Status new => resolved
2017-09-03 22:10 Ondrej Pokorny Resolution open => duplicate
2017-09-03 22:10 Ondrej Pokorny Assigned To => Ondrej Pokorny
2017-09-03 22:11 Ondrej Pokorny Relationship added related to 0031527
2017-09-03 22:12 Ondrej Pokorny Note Added: 0102623