View Issue Details

IDProjectCategoryView StatusLast Update
0032427LazarusIDEpublic2017-09-17 12:36
ReporterCudaText man Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux gtk2 x64 
Product Version1.9 (SVN) 
Summary0032427: Regression: OI, obj list not updated
DescriptionATTabs demo program form.

- focus first checkbox on form designer
- call OI, rename (using Name field) check from chkPlus to chkShowPlus, press Enter
- OI's top combobox (list of objects) still shows "chkPlus" (and dropdown list too)
TagsNo tags attached.
Fixed in Revisionr55877
LazTarget-
Widgetset
Attached Files

Activities

wp

2017-09-16 20:00

developer   ~0102871

If you are sure that this is a bug of the LCL or the Object Inspector you must demonstrate the problem with LCL-only components. No one is going to look at a third-party component which can have its own bugs.

CudaText man

2017-09-16 20:28

reporter   ~0102872

Last edited: 2017-09-16 20:29

View 2 revisions

wp,
It is repro with any new application, new form, one Checkbox on a form.

wp

2017-09-16 23:55

developer   ~0102878

What is "chkPlus" and "chkShowPlus"? What is "OI's top combobox (list of objects)"? Can you add a screenshot to explain what you mean?

CudaText man

2017-09-17 00:24

reporter  

oi-combobox-on-top.png (28,042 bytes)   
oi-combobox-on-top.png (28,042 bytes)   

CudaText man

2017-09-17 00:25

reporter   ~0102879

Last edited: 2017-09-17 00:26

View 2 revisions

- chkPlus - old name of combobox (for new form name is "ComboBox1")
- chkShowPlus - renamed combobox
- picture added (for name "ComboBox1")

wp

2017-09-17 01:15

developer   ~0102880

Last edited: 2017-09-17 01:16

View 2 revisions

It took me some time to find out that you turned off the component tree in the object inspector; otherwise that top combobox which is outlined in brown/orange color in your screenshot is not shown.

Yes, in this mode of operation I can confirm that the name of the renamed component is not updated correctly. This is not only a gtk2 and 64bit issue, it also happens on Windows and 32 bit Laz. In Laz 1.6.4, the behavior still was correct. I don't have the old RCs of Laz 1.8, but the issue is seen at least after RC3 (in trunk, as well). Therefore, I changed the title to emphasize that this is a regression.

In the component tree which is displayed by default the component name is updated correctly.

Serge Anvarov

2017-09-17 03:22

reporter   ~0102881

Windows. Laz 1.8, RC4. No error on 32 and 64 bit.

wp

2017-09-17 11:08

developer   ~0102883

Did you test with the component tree (it works) or without it (it does not work)?

Juha Manninen

2017-09-17 11:08

developer   ~0102884

I can reproduce. I guess this is caused by my changes.

Juha Manninen

2017-09-17 12:36

developer   ~0102886

Fixed, please test.
Will be merged to 1.8, just in time. :)

Issue History

Date Modified Username Field Change
2017-09-16 19:16 CudaText man New Issue
2017-09-16 20:00 wp Note Added: 0102871
2017-09-16 20:28 CudaText man Note Added: 0102872
2017-09-16 20:29 CudaText man Note Edited: 0102872 View Revisions
2017-09-16 23:55 wp Note Added: 0102878
2017-09-17 00:24 CudaText man File Added: oi-combobox-on-top.png
2017-09-17 00:25 CudaText man Note Added: 0102879
2017-09-17 00:26 CudaText man Note Edited: 0102879 View Revisions
2017-09-17 01:10 wp LazTarget => -
2017-09-17 01:10 wp Summary OI, obj list not updated => Regression: OI, obj list not updated
2017-09-17 01:15 wp Note Added: 0102880
2017-09-17 01:16 wp Note Edited: 0102880 View Revisions
2017-09-17 01:17 wp Status new => confirmed
2017-09-17 03:22 Serge Anvarov Note Added: 0102881
2017-09-17 11:06 Juha Manninen Assigned To => Juha Manninen
2017-09-17 11:06 Juha Manninen Status confirmed => assigned
2017-09-17 11:08 wp Note Added: 0102883
2017-09-17 11:08 Juha Manninen Note Added: 0102884
2017-09-17 12:36 Juha Manninen Fixed in Revision => r55877
2017-09-17 12:36 Juha Manninen Note Added: 0102886
2017-09-17 12:36 Juha Manninen Status assigned => resolved
2017-09-17 12:36 Juha Manninen Resolution open => fixed