View Issue Details

IDProjectCategoryView StatusLast Update
0032521LazarusRTLpublic2017-10-09 12:28
ReporterAlexey Tor.Assigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformFreeBSD 11.1 x64OSOS Version
Product Version1.8RC1Product Build 
Target VersionFixed in Version 
Summary0032521: App for FreeBSD don't run, until I make symlink libiconv.so.3=> libiconv.so.2
DescriptionApp is CudaText.
Its binary file dont run, until I make symlink.
%subj%.
App cannot find libiconv.so.3 on start.
And I installed xfce desktop [with GTK2 and GTK3].
So needing of this file in an issue.
Pls use only libiconv.so.2.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Alexey Tor.

2017-10-07 21:05

reporter   ~0103240

Lazarus isnot installed on this PC, only CudaText is tested.

Juha Manninen

2017-10-08 01:25

developer   ~0103244

Why do you report this for Lazarus project? It does not use libiconv directly.
Unit LConvEncoding uses iconvenc from FPC sources but I don't see the library version defined there. It means the bug is in your FreeBSD system.
Please try to analyse the bugs a little before reporting.

Alexey Tor.

2017-10-08 08:15

reporter   ~0103245

So it is FPC issue, please change report field to make it FPC report.

Alexey Tor.

2017-10-08 08:31

reporter   ~0103247

It is FPC 3.0.4.

Juha Manninen

2017-10-08 10:52

developer   ~0103250

No, it is a FreeBSD issue. Please concentrate on the quality of your bug reports. Many of them are not valid, thus polluting the bug tracker.
You could ask about libiconv issues in FPC mailing list. There are FreeBSD users.

Alexey Tor.

2017-10-08 12:36

reporter   ~0103251

Sorry. But i still think this is OK report- for FPC or Laz.
But OK- close this issue if you cant help.

Marco van de Voort

2017-10-08 14:03

manager   ~0103256

- *nix binaries are not very crossversion portable. We have no power to fix that.
- FPC sources itself do not try to load a specific version. The installation on which the binary (CudaText) was linked probably chose the version, not FPC

Note there are also _dyn versions of the iconv library that allow you to load the library manually.

Recommend to close.

Juha Manninen

2017-10-09 12:28

developer   ~0103277

Resolving.
AlexeyT, I still wonder why you thought the bug was in Lazarus. Even a simple primitive analysis proved it is not.

Issue History

Date Modified Username Field Change
2017-10-07 20:55 Alexey Tor. New Issue
2017-10-07 21:05 Alexey Tor. Note Added: 0103240
2017-10-08 01:25 Juha Manninen Note Added: 0103244
2017-10-08 08:15 Alexey Tor. Note Added: 0103245
2017-10-08 08:31 Alexey Tor. Note Added: 0103247
2017-10-08 10:52 Juha Manninen Note Added: 0103250
2017-10-08 12:36 Alexey Tor. Note Added: 0103251
2017-10-08 14:03 Marco van de Voort Note Added: 0103256
2017-10-09 12:28 Juha Manninen LazTarget => -
2017-10-09 12:28 Juha Manninen Note Added: 0103277
2017-10-09 12:28 Juha Manninen Status new => resolved
2017-10-09 12:28 Juha Manninen Resolution open => no change required
2017-10-09 12:28 Juha Manninen Assigned To => Juha Manninen