View Issue Details

IDProjectCategoryView StatusLast Update
0032536LazarusLCLpublic2017-10-12 15:28
ReporterM.AUDIO Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformanyOSwin xubuntu 
Product Version1.9 (SVN) 
Summary0032536: TFileNameEdit eats Focus.
DescriptionTFileNameEdit eats Focus and can't use Tab key to navigate to other controls after it gets focused.
Steps To Reproduceattached simple project with one TFileNameEdit and two TButton. (no extra setting. just dropped on the form and compiled.)
TagsFocus, Tab Stop, TFileNameEdit
Fixed in Revision
LazTarget-
WidgetsetGTK 2, Win32/Win64
Attached Files

Relationships

duplicate of 0032533 closedMichl TDateEdit/TTimeEdit controls break the tab order 
related to 0032335 resolvedOndrej Pokorny TDateEdit: SelectNext doesn't work 

Activities

M.AUDIO

2017-10-12 09:55

reporter  

Juha Manninen

2017-10-12 11:06

developer   ~0103373

Wasn't this just fixed? See the related issues.

M.AUDIO

2017-10-12 15:12

reporter   ~0103376

OK.
now I'm on r56034 and it seems to be fixed (win7 and xubuntu). thanks.

Juha Manninen

2017-10-12 15:28

developer   ~0103377

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2017-10-12 09:55 M.AUDIO New Issue
2017-10-12 09:55 M.AUDIO File Added: filenameedittabstop.zip
2017-10-12 09:56 M.AUDIO Tag Attached: Focus
2017-10-12 09:56 M.AUDIO Tag Attached: TFileNameEdit
2017-10-12 09:56 M.AUDIO Tag Attached: Tab Stop
2017-10-12 11:05 Juha Manninen Relationship added related to 0032533
2017-10-12 11:06 Juha Manninen Relationship added related to 0032335
2017-10-12 11:06 Juha Manninen Note Added: 0103373
2017-10-12 15:12 M.AUDIO Note Added: 0103376
2017-10-12 15:28 Juha Manninen LazTarget => -
2017-10-12 15:28 Juha Manninen Note Added: 0103377
2017-10-12 15:28 Juha Manninen Relationship replaced duplicate of 0032533
2017-10-12 15:28 Juha Manninen Status new => resolved
2017-10-12 15:28 Juha Manninen Resolution open => duplicate
2017-10-12 15:28 Juha Manninen Assigned To => Juha Manninen