View Issue Details

IDProjectCategoryView StatusLast Update
0032546LazarusPackagespublic2017-10-16 15:46
ReporterColin Haywood Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindows 
Summary0032546: Incorrect behaviour and crash when moving items up and down in the list of package files
DescriptionSorry, can't find the category for the Lazarus IDE. I'm using Lazarus 1.6.4.

When editing a package in the Package Editor, if you select a file and click the "Move selected item down" button, a different file other than the one selected moves. In addition, the selection is not updated visually, so further clicks move the same item down even though it is no longer selected.

No doubt related to this apparent indexing error, clicking on the bottom file in the list and choosing "Move selected item up" will cause Lazarus to crash with an index out of range error.
TagsNo tags attached.
Fixed in Revisionr56058, r56068, r56082
LazTarget-
Widgetset
Attached Files

Activities

Cyrax

2017-10-14 14:01

reporter   ~0103423

Someone move this to Lazarus side of bug tracker, please.

Michl

2017-10-14 18:08

developer   ~0103425

Last edited: 2017-10-14 18:12

View 2 revisions

For files I can't replicate it on current trunk, but for required packages. Test basic package added. Try to move a required packages with minimal version info (here LCL 1 .0) gives a AV.

TPackageEditorForm.DoMoveDependency
...
OldIndex:=RequiredBranch.Items.IndexOf(FSingleSelectedDep.PackageName); <-- the name doesn't match

Maybe that is the same problem with the files?!

Michl

2017-10-14 18:08

developer  

BasicPackage.zip (1,123 bytes)

Juha Manninen

2017-10-15 13:51

developer   ~0103444

Last edited: 2017-10-16 15:45

View 4 revisions

I fixed moving the dependencies in r56058.
The files portion does not have a similar display name issue. I cannot reproduce the other problems.
In r56068 I improved updating of the view when package attributes are changed.
r56082 updates a dependent package's icon after min/max version is changed.
These will be merged to 1.8. Resolving.

Issue History

Date Modified Username Field Change
2017-10-14 01:25 Colin Haywood New Issue
2017-10-14 14:01 Cyrax Note Added: 0103423
2017-10-14 15:24 Marco van de Voort Project FPC => Lazarus
2017-10-14 18:08 Michl Note Added: 0103425
2017-10-14 18:08 Michl File Added: BasicPackage.zip
2017-10-14 18:10 Michl LazTarget => -
2017-10-14 18:10 Michl Status new => confirmed
2017-10-14 18:12 Michl Note Edited: 0103425 View Revisions
2017-10-15 13:26 Juha Manninen Assigned To => Juha Manninen
2017-10-15 13:26 Juha Manninen Status confirmed => assigned
2017-10-15 13:51 Juha Manninen Note Added: 0103444
2017-10-15 13:52 Juha Manninen Note Edited: 0103444 View Revisions
2017-10-15 13:52 Juha Manninen Status assigned => feedback
2017-10-16 12:00 Juha Manninen Note Edited: 0103444 View Revisions
2017-10-16 15:45 Juha Manninen Note Edited: 0103444 View Revisions
2017-10-16 15:46 Juha Manninen Fixed in Revision => r56058, r56068, r56082
2017-10-16 15:46 Juha Manninen Status feedback => resolved
2017-10-16 15:46 Juha Manninen Resolution open => fixed