View Issue Details

IDProjectCategoryView StatusLast Update
0032606LazarusIDEpublic2017-11-13 15:42
ReporterDmitry D. Chernov Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386-win32OSWindows 
Product Version1.6.4 
Summary0032606: "Find declaration" for an unit name fails if caret placed between name and comma
Description$subj
Steps To Reproduce0. Assume we have the next code:

  uses
    Classes, SysUtils;

1. Set the caret as follows:

  uses
    Classes|, SysUtils;

2. Press Right Mouse Key and select "Find declaration".

3. It failed. :c
TagsNo tags attached.
Fixed in Revisionr56366
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Ondrej Pokorny

2017-10-24 14:18

developer   ~0103735

Yes, I have been annoyed by it for a long time as well :)

jamie philbrook

2017-10-24 17:55

reporter   ~0103738

Seems to be random, because it does work for me most of the time.

Dmitry D. Chernov

2017-10-24 18:39

reporter   ~0103740

It's not random at all.

jamie philbrook

2017-10-25 14:28

reporter   ~0103761

for you that maybe the case but for me your example works 95% of the
time and when it does not all I do is shuffle the line the other 5%.

Juha Manninen

2017-11-11 17:07

developer   ~0104004

Fixed, please test.

Ondrej Pokorny

2017-11-11 20:16

developer   ~0104008

Works well for me. Good work, thanks Juha.

Dmitry D. Chernov

2017-11-13 15:42

reporter   ~0104073

It works, thank you.

Issue History

Date Modified Username Field Change
2017-10-24 06:21 Dmitry D. Chernov New Issue
2017-10-24 14:18 Ondrej Pokorny LazTarget => -
2017-10-24 14:18 Ondrej Pokorny Note Added: 0103735
2017-10-24 14:18 Ondrej Pokorny Status new => confirmed
2017-10-24 17:55 jamie philbrook Note Added: 0103738
2017-10-24 18:39 Dmitry D. Chernov Note Added: 0103740
2017-10-25 14:28 jamie philbrook Note Added: 0103761
2017-11-11 17:00 Juha Manninen Assigned To => Juha Manninen
2017-11-11 17:00 Juha Manninen Status confirmed => assigned
2017-11-11 17:07 Juha Manninen Fixed in Revision => r56366
2017-11-11 17:07 Juha Manninen Note Added: 0104004
2017-11-11 17:07 Juha Manninen Status assigned => resolved
2017-11-11 17:07 Juha Manninen Resolution open => fixed
2017-11-11 20:16 Ondrej Pokorny Note Added: 0104008
2017-11-13 15:42 Dmitry D. Chernov Note Added: 0104073
2017-11-13 15:42 Dmitry D. Chernov Status resolved => closed