View Issue Details

IDProjectCategoryView StatusLast Update
0032619LazarusIDEpublic2017-11-06 22:08
ReporterHartmut Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSWindows 
Product Version1.8RC5 
Summary0032619: Search/Find dialog forgets last used origin
DescriptionWhen you open the Search/Find dialog, the origin shows nearly always "From cursor", even if you have set it to "From beginning" last time.
in Lazarus 1.6.2 and older the last used origin was remembered.
Steps To Reproduce - open the Search/Find dialog e.g. with CTRL+F
 - set the origin to "From beginning"
 - search something
 - after that click anywhere in the Editor window (without that, the error won't occur)
 - open the Search/Find dialog again
Result: the origin is set back to "From cursor"
TagsNo tags attached.
Fixed in Revision56256, 56325
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0027039 closedOndrej Pokorny The replace function does not replace selected text. 

Activities

Juha Manninen

2017-11-01 14:49

developer   ~0103843

Fixed.
The logic was changed by Ondrej when fixing the related issue in r51697 at 2016-02-25.
I am not sure if this particular feature was planned but I think it is better now. The "Origin" is remembered.

Ondrej Pokorny

2017-11-06 19:46

developer   ~0103919

Juha, why don't you ping me if I was the one who changed it? Now we are fighting changes against one another. Better would be to discuss it.

I changed it because Delphi and Notepad behave so.

Btw. it doesn't work now either. The origin changes to "from beginning" if I select a text and hit Ctrl+F and it doesn't go back :/

Ondrej Pokorny

2017-11-06 21:14

developer   ~0103924

I fixed it with storing the options depending on selection availability.

FTurtle

2017-11-06 21:45

reporter   ~0103927

r56256 was merged to 1.8
Don't forget about r56325

Ondrej Pokorny

2017-11-06 22:08

developer   ~0103929

FTurtle, thanks for the reminder.

Issue History

Date Modified Username Field Change
2017-10-27 18:02 Hartmut New Issue
2017-11-01 14:31 Juha Manninen Relationship added related to 0027039
2017-11-01 14:40 Juha Manninen Assigned To => Juha Manninen
2017-11-01 14:40 Juha Manninen Status new => assigned
2017-11-01 14:49 Juha Manninen Fixed in Revision => r56256
2017-11-01 14:49 Juha Manninen LazTarget => -
2017-11-01 14:49 Juha Manninen Note Added: 0103843
2017-11-01 14:49 Juha Manninen Status assigned => resolved
2017-11-01 14:49 Juha Manninen Resolution open => fixed
2017-11-06 19:46 Ondrej Pokorny Assigned To Juha Manninen => Ondrej Pokorny
2017-11-06 19:46 Ondrej Pokorny Note Added: 0103919
2017-11-06 19:46 Ondrej Pokorny Status resolved => assigned
2017-11-06 19:46 Ondrej Pokorny Resolution fixed => reopened
2017-11-06 21:14 Ondrej Pokorny Fixed in Revision r56256 => 56256, 56325
2017-11-06 21:14 Ondrej Pokorny Note Added: 0103924
2017-11-06 21:14 Ondrej Pokorny Status assigned => resolved
2017-11-06 21:14 Ondrej Pokorny Resolution reopened => fixed
2017-11-06 21:45 FTurtle Note Added: 0103927
2017-11-06 22:08 Ondrej Pokorny Note Added: 0103929