View Issue Details

IDProjectCategoryView StatusLast Update
0032660PackagesPackagespublic2017-11-10 12:21
ReporterPascal Riekenberg Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindows 10 x64 
Product Version1.9 (SVN) 
Summary0032660: Anchordoching: Loading layout twice destroys layout
DescriptionIf you load a layout twice the layout gets destroyed.
Steps To ReproduceOpen and run project miniide and load the attached layout.
The layout is ok.
Now load it a sewcond time.
The layout is broken.
Additional InformationThis already was fixed some time ago now it's there again!
TagsNo tags attached.
Fixed in Revisionr56349
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0032591 resolvedJuha Manninen Lazarus Anchor docking fall with AV and hang IDE after moving Code Explorer to another place 

Activities

Pascal Riekenberg

2017-11-08 09:24

developer  

layout01.xml (1,883 bytes)   
<?xml version="1.0" encoding="utf-8"?>
<CONFIG>
  <MainConfig>
    <Nodes ChildCount="1">
      <Item1 Name="MainIDE" Type="CustomSite" ChildCount="1">
        <Bounds Top="57" Left="173" Width="954" Height="484">
          <WorkArea>
            <Rect Right="1920" Bottom="1040"/>
          </WorkArea>
        </Bounds>
        <Item1 Name="AnchorDockSite1" Type="Layout" ChildCount="5">
          <Bounds Top="64" Width="954" Height="400" SplitterPos="59"/>
          <Anchors Align="Bottom"/>
          <Item1 Name="SourceEditor1" Type="Control">
            <Bounds Left="567" Width="387" Height="400"/>
            <Anchors Left="AnchorDockSplitter2"/>
          </Item1>
          <Item2 Name="AnchorDockSplitter2" Type="SplitterVertical">
            <Bounds Left="563" Width="4" Height="400"/>
          </Item2>
          <Item3 Name="Messages" Type="Control">
            <Bounds Top="204" Width="563" Height="196"/>
            <Anchors Top="AnchorDockSplitter3" Right="AnchorDockSplitter2"/>
          </Item3>
          <Item4 Name="AnchorDockSplitter3" Type="SplitterHorizontal">
            <Bounds Top="200" Width="563" Height="4"/>
            <Anchors Right="AnchorDockSplitter2"/>
          </Item4>
          <Item5 Name="AnchorDockSite3" Type="Pages" ChildCount="2">
            <Bounds Width="563" Height="200"/>
            <Anchors Right="AnchorDockSplitter2" Bottom="AnchorDockSplitter3"/>
            <Item1 Name="ObjectInspector" Type="Control">
              <Bounds Width="320" Height="240"/>
              <Anchors Align="Client"/>
            </Item1>
            <Item2 Name="FPDocEditor" Type="Control">
              <Bounds Width="555" Height="172"/>
              <Anchors Align="Client"/>
            </Item2>
          </Item5>
        </Item1>
      </Item1>
    </Nodes>
  </MainConfig>
</CONFIG>
layout01.xml (1,883 bytes)   

Andrey Zubarev

2017-11-08 18:21

reporter   ~0103963

I can't reproduce. everything works in win32

Pascal Riekenberg

2017-11-08 19:58

developer   ~0103965

Okay?! I'll try plain trunk.

Pascal Riekenberg

2017-11-08 20:23

developer   ~0103966

Tried again with fresh fpc trunk and lazarus trunk. See attached screenshots.

Pascal Riekenberg

2017-11-08 20:23

developer  

first.PNG (16,266 bytes)   
first.PNG (16,266 bytes)   

Pascal Riekenberg

2017-11-08 20:23

developer  

second.PNG (10,454 bytes)   
second.PNG (10,454 bytes)   

Andrey Zubarev

2017-11-09 06:09

reporter   ~0103968

Sorry, i try it in old minide.exe. It reproduced

Andrey Zubarev

2017-11-09 19:47

reporter   ~0103975

error in r56156

Pascal Riekenberg

2017-11-10 05:41

developer   ~0103983

Andrey, can you fix it?

Andrey Zubarev

2017-11-10 08:33

reporter   ~0103984

this
Index: anchordocking.pas
===================================================================
--- anchordocking.pas (revision 56343)
+++ anchordocking.pas (working copy)
@@ -3436,7 +3436,8 @@
     RaiseGDBException('');
   dec(fUpdateCount);
   if fUpdateCount=0 then
- QueueSimplify:=True;
+ SimplifyPendingLayouts;
+ //QueueSimplify:=True;
 end;
 
 procedure TAnchorDockMaster.NeedSimplify(AControl: TControl);

fix it for me, but need reopen issue 32591 for this

Juha Manninen

2017-11-10 09:48

developer   ~0103986

Please test with r56349. I applied the change proposed by Andrey.

Pascal Riekenberg

2017-11-10 10:36

developer   ~0103990

Yes, works! Thanks!

Issue History

Date Modified Username Field Change
2017-11-08 09:24 Pascal Riekenberg New Issue
2017-11-08 09:24 Pascal Riekenberg File Added: layout01.xml
2017-11-08 18:21 Andrey Zubarev Note Added: 0103963
2017-11-08 19:58 Pascal Riekenberg Note Added: 0103965
2017-11-08 20:23 Pascal Riekenberg Note Added: 0103966
2017-11-08 20:23 Pascal Riekenberg File Added: first.PNG
2017-11-08 20:23 Pascal Riekenberg File Added: second.PNG
2017-11-09 06:09 Andrey Zubarev Note Added: 0103968
2017-11-09 19:47 Andrey Zubarev Note Added: 0103975
2017-11-09 21:02 Michl Relationship added related to 0032591
2017-11-09 21:03 Michl Assigned To => Juha Manninen
2017-11-09 21:03 Michl Status new => assigned
2017-11-10 05:41 Pascal Riekenberg Note Added: 0103983
2017-11-10 08:33 Andrey Zubarev Note Added: 0103984
2017-11-10 09:48 Juha Manninen LazTarget => -
2017-11-10 09:48 Juha Manninen Note Added: 0103986
2017-11-10 09:48 Juha Manninen Status assigned => feedback
2017-11-10 10:36 Pascal Riekenberg Note Added: 0103990
2017-11-10 10:36 Pascal Riekenberg Status feedback => assigned
2017-11-10 10:54 Juha Manninen Fixed in Revision => r56349
2017-11-10 10:54 Juha Manninen Status assigned => resolved
2017-11-10 10:54 Juha Manninen Resolution open => fixed
2017-11-10 12:21 Pascal Riekenberg Status resolved => closed