View Issue Details

IDProjectCategoryView StatusLast Update
0032676LazarusIDEpublic2017-11-12 18:15
ReporterBenito van der Zander Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionduplicate 
Product Version1.8RC5 
Summary0032676: lazbuild exception
DescriptionI was running lazbuild from http://mirrors.iwi.me/lazarus/releases/Lazarus%20Linux%20amd64%20DEB/Lazarus%201.8.0RC5/ on Travis CI and it crashed when compiling my project:


Warning: (lazarus) [TLazPackageGraph.ConvertPackageRSTFiles] skipping read only directory /usr/share/lazarus/1.8.0RC5/lcl/languages/
An unhandled exception occurred at $0000000000000000:
EAccessViolation: Access violation
  $0000000000000000
  $0000000000579F17
  $000000000057B121

TProject.DoLoadStateFile Statefile not found: /home/travis/build/benibela/sf/programs/internet/VideLibri/android/lib/i386-android/.compiled
An unhandled exception occurred at $00000000004EDEF8:
EAccessViolation: Access violation
  $00000000004EDEF8
  $00000000004F3B97
  $00000000009E2840
  $00000000009E1C4C
  $000000000040473F
  $0000000000403C36
  $0000000000401E05
  $00000000004077F5
  $000000000040A48F

An unhandled exception occurred at $0000000000414B35:
EAccessViolation: Access violation
  $0000000000414B35
  $000000000040A48F

FAILED!

Then I restarted the build (which reinstalls everything on a new VM) and it did not happen again ( https://travis-ci.org/benibela/videlibri/jobs/300738001 )
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0032340 resolvedJuha Manninen lazbuild exception 

Activities

Juha Manninen

2017-11-12 00:49

developer   ~0104021

You should provide a proper stacktrace. It helps to fix a bug which a developer cannot reproduce.

> and it did not happen again

How to reproduce it then?

Juha Manninen

2017-11-12 18:15

developer   ~0104041

Resolving this one as duplicate.

Issue History

Date Modified Username Field Change
2017-11-12 00:38 Benito van der Zander New Issue
2017-11-12 00:49 Juha Manninen Note Added: 0104021
2017-11-12 18:14 Juha Manninen Relationship added duplicate of 0032340
2017-11-12 18:15 Juha Manninen LazTarget => -
2017-11-12 18:15 Juha Manninen Note Added: 0104041
2017-11-12 18:15 Juha Manninen Status new => resolved
2017-11-12 18:15 Juha Manninen Resolution open => duplicate
2017-11-12 18:15 Juha Manninen Assigned To => Juha Manninen