View Issue Details

IDProjectCategoryView StatusLast Update
0032693LazarusTAChartpublic2017-11-26 11:52
ReporterW.YAssigned Towp 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformWindows 7 32-64OSOS Version
Product Version1.8RC5Product Build 
Target Version1.9 (SVN)Fixed in Version1.9 (SVN) 
Summary0032693: Modifing ChartBarSeries.Marks.Attachment=maCenter property.
Descriptionif ChartBarSeries.Marks.Attachment=maCenter

ChartBarSeries.Marks.Label appears fig1:


I hope that it will appears fig2:
TagsNo tags attached.
Fixed in Revision56416
LazTargetpost 1.8
WidgetsetWin32/Win64
Attached Files

Activities

W.Y

2017-11-14 17:29

reporter  

Barres.png (33,633 bytes)
Barres.png (33,633 bytes)

wp

2017-11-14 18:02

developer   ~0104103

There is no question in your report, and so I have to guess:

If Marks.Attachment is maCenter then the marks are centered with respect to the data point. In case of a BarSeries, this is the end of the bar (this is where a line series would run, if the BarSeries would be replaced by a LineSeries). Therefore this behavior is logical. But I could imagine that you want to center the marks inside the bar. Is that what you request?

wp

2017-11-15 15:53

developer   ~0104113

Last edited: 2017-11-15 16:08

View 3 revisions

In case you want centered marks inside the bars of a BarSeries you should have a look at r56416: the new option lmpInsideCentered of TBarSeries.MarkPositions centers all marks inside the corresponding bar. See attached screenshot.

Please respond if this answers your question so that I can mark the report as resolved.

wp

2017-11-15 16:08

developer  

MarksInsideCentered.png (11,001 bytes)
MarksInsideCentered.png (11,001 bytes)

W.Y

2017-11-15 17:09

reporter   ~0104115

Last edited: 2017-11-19 12:41

View 4 revisions

hello wp

In fact I used ImpInside before in my application but it's not enough because it's not centered.

I used this fuction to centered it ChartPrix_ZMois.Marks.Distance:=68-4*compt;//compt:integer;

 you can download the demo from this address(if you have an account): https://lazarus.developpez.com/telecharger/index/categorie/79/Lazarus
titled: X-parameters

to see it.

wp

2017-11-15 17:33

developer   ~0104117

Last edited: 2017-11-15 19:13

View 3 revisions

lmpInsideCentered is a new value of the property TBarSeries.MarkPositions. It calculates the center of the bar and puts the label at this place. But note that Marks.Distance has a default value of 20; to get perfect centering you must reset this to 0.

Please don't link to sources outside the bugtracker. They may disappear at some time and are useless then. And since this one is on a French site and I can't read French, I am lost. And if you even require me to register somewhere I can assure you that I definitely will not look at this code!

In order to upload sources here pack pas, lfm, lpr, and lpi files into a common zip which you can upload under "Upload file". But only short demos, I will not take the time to seek through large applications.

W.Y

2017-11-16 15:00

reporter   ~0104136

Last edited: 2017-11-16 18:44

View 3 revisions

hello wp,

because lmpInsideCentered is a new value of the property TBarSeries.MarkPositions, certainly in laz 1.8 RC6.
I am satisfied and you can set this as resolved.

thanks a lot.

W.Y

2017-11-16 18:24

reporter  

XParameters.rar (1,391,512 bytes)

wp

2017-11-16 19:12

developer   ~0104145

Well - it is a new feature. Normally, the new version, Laz 1.8, would be fine for it. But it is about to be released soon, and I do not want to take the risk of breaking anything at this time.

Did you test the fix? For testing you must install trunk, the developer version.

W.Y

2017-11-17 01:13

reporter   ~0104148

Last edited: 2017-11-17 01:14

View 2 revisions

Thanks wp
well I am waiting for the new Laz version.

wp

2017-11-25 11:41

developer   ~0104253

Resolving, it works in my tests.

W.Y

2017-11-26 11:00

reporter   ~0104272

Hello,
Ok you can close it!

wp

2017-11-26 11:52

developer   ~0104277

Normally it is the poster who "closes" a report. But I'll do it for you...

Issue History

Date Modified Username Field Change
2017-11-14 17:29 W.Y New Issue
2017-11-14 17:29 W.Y File Added: Barres.png
2017-11-14 18:00 wp LazTarget => -
2017-11-14 18:00 wp Assigned To => wp
2017-11-14 18:00 wp Status new => feedback
2017-11-14 18:02 wp Note Added: 0104103
2017-11-14 18:49 wp Category LCL => TAChart
2017-11-15 15:53 wp Note Added: 0104113
2017-11-15 15:54 wp Note Edited: 0104113 View Revisions
2017-11-15 16:08 wp File Added: MarksInsideCentered.png
2017-11-15 16:08 wp Note Edited: 0104113 View Revisions
2017-11-15 17:09 W.Y Note Added: 0104115
2017-11-15 17:09 W.Y Status feedback => assigned
2017-11-15 17:33 wp Note Added: 0104117
2017-11-15 19:12 wp Note Edited: 0104117 View Revisions
2017-11-15 19:13 wp Note Edited: 0104117 View Revisions
2017-11-16 15:00 W.Y Note Added: 0104136
2017-11-16 18:24 W.Y File Added: XParameters.rar
2017-11-16 18:25 W.Y Note Edited: 0104115 View Revisions
2017-11-16 18:26 W.Y Note Edited: 0104136 View Revisions
2017-11-16 18:44 W.Y Note Edited: 0104136 View Revisions
2017-11-16 19:12 wp Note Added: 0104145
2017-11-17 01:13 W.Y Note Added: 0104148
2017-11-17 01:14 W.Y Note Edited: 0104148 View Revisions
2017-11-18 13:28 W.Y Note Edited: 0104115 View Revisions
2017-11-19 12:41 W.Y Note Edited: 0104115 View Revisions
2017-11-25 11:41 wp Fixed in Revision => 56416
2017-11-25 11:41 wp LazTarget - => post 1.8
2017-11-25 11:41 wp Note Added: 0104253
2017-11-25 11:41 wp Status assigned => resolved
2017-11-25 11:41 wp Fixed in Version => 1.9 (SVN)
2017-11-25 11:41 wp Resolution open => fixed
2017-11-25 11:41 wp Target Version => 1.9 (SVN)
2017-11-26 11:00 W.Y Note Added: 0104272
2017-11-26 11:52 wp Note Added: 0104277
2017-11-26 11:52 wp Status resolved => closed