View Issue Details

IDProjectCategoryView StatusLast Update
0032732PackagesPackagespublic2017-12-11 23:57
ReporterVolker lux Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSWindows 
Product Version1.8RC4 
Summary0032732: TFBAdmin (SQLdb page) component not eraseable from the form or close project = access violation
DescriptionClosing a project with TFBAdmin component on the form raises always an 'Access violation' error.
Put just the FBAdmin component on an empty form, try to delete it or close the project -> Access violation.
A project compiles without any errors and works properly but during development the error araises.
In Lazarus 1.6.4 everything is fine. I am not sure since which version this bug came up.
Steps To Reproduce
Put just the FBAdmin component on an empty form, try to delete it or close the project -> Access violation.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0032304 resolvedMichael Van Canneyt FPC FBAdmin gives errors when added to an empty project 
related to 0032801 resolvedMichael Van Canneyt FPC when I close IDE: Access violation 

Activities

Juha Manninen

2017-11-27 18:25

developer   ~0104314

Last edited: 2017-11-27 19:03

View 2 revisions

I cannot reproduce with Lazarus trunk neither on Windows nor on Linux using GTK2 or QT bindings.
Can you please test also with trunk.

Can anybody else reproduce?

LacaK

2017-11-28 09:39

developer   ~0104320

I cannot reproduce with Lazarus 1.9 + FPC 3.1.1 Trunk from October 2017

José Mejuto

2017-11-28 10:28

developer   ~0104321

Maybe related to this: https://bugs.freepascal.org/view.php?id=32304

Juha Manninen

2017-11-28 13:28

developer   ~0104325

Yes, that's why this issue felt familiar.
It was fixed by a patch from Michl. I don't fully understand his comment :
 "I added a minimal example and a patch. It comes with FPC 3.0.2 and is still in trunk 3.1.1."
but it is fixed in FPC trunk anyway.
So this Lazarus issue cannot be fixed except by using FPC trunk.
Resolving...

Soner

2017-12-11 23:57

reporter   ~0104647

Call of DisConnect in TFBAdmin.Destroy causes the bug.
IN fpc 3.0.2 it was:
destructor TFBAdmin.Destroy;
begin
  if FSvcHandle<>FB_API_NULLHANDLE then
    DisConnect;
  FOutput.Destroy;
  inherited Destroy;
end;

Someone made it in 3.0.4 to:

destructor TFBAdmin.Destroy;
begin
  if FSvcHandle<>FB_API_NULLHANDLE then
  WaitInterval:=100;
    DisConnect;
  FOutput.Destroy;
  inherited Destroy;
end;

----
Make following changes and recompile it to use it in fpc 3.0.4 again:
destructor TFBAdmin.Destroy;
begin
  if FSvcHandle<>FB_API_NULLHANDLE then begin
    WaitInterval:=100;
    DisConnect;
  end;
  FOutput.Destroy;
  inherited Destroy;
end;

Issue History

Date Modified Username Field Change
2017-11-26 16:47 Volker lux New Issue
2017-11-27 18:25 Juha Manninen Note Added: 0104314
2017-11-27 18:25 Juha Manninen LazTarget => -
2017-11-27 18:25 Juha Manninen Assigned To => Juha Manninen
2017-11-27 18:25 Juha Manninen Status new => feedback
2017-11-27 19:03 Juha Manninen Note Edited: 0104314 View Revisions
2017-11-28 09:39 LacaK Note Added: 0104320
2017-11-28 10:28 José Mejuto Note Added: 0104321
2017-11-28 11:09 Juha Manninen Relationship added related to 0032304
2017-11-28 13:28 Juha Manninen Note Added: 0104325
2017-11-28 13:28 Juha Manninen Status feedback => resolved
2017-11-28 13:28 Juha Manninen Resolution open => fixed
2017-12-09 15:56 Juha Manninen Relationship added related to 0032801
2017-12-11 23:57 Soner Note Added: 0104647