View Issue Details

IDProjectCategoryView StatusLast Update
0032773FPCOtherpublic2018-04-01 09:32
ReporterRossAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformwin64OSWindowsOS Version7
Product Version3.0.0Product Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0032773: paszlib inflate of file gives crc error
DescriptionWhen unzipping a zip file created with paszlib, the file javafx_font_t2k.dll from the Java JRE I get a CRC error.
This only happens when compression level is set to normal, it extracts fine when compressed with fastest or max level.
Both compression and extraction are done with paszlib.
Steps To ReproduceUse paszlib to compress to zip file the contents of the latest Java JRE bin folder, use normal compression level.
Use paszlib to extract the files. You get CRC error when trying to extract the javafx_font_t2k.dll file.

Additional InformationOnly throws CRC error when file is compressed with normal level.
TagsNo tags attached.
Fixed in Revision38657
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0031219 resolvedMichael Van Canneyt paszlib, unable to extract with "out of range" error 
related to 0033493 closedMichael Van Canneyt fix-patch for 0026827-bug for packages\paszlib\src\infcodes.pas, fixes "out of range" on decompressing 

Activities

Marco van de Voort

2017-12-05 14:53

manager   ~0104454

Please retry with a current version (3.0.4), and/or provide a minimal program (+ content to zip).

Ross

2017-12-06 03:38

reporter  

ziptest.zip (130,083 bytes)

Ross

2017-12-06 03:39

reporter  

javafx_font_t2k.dll (538,656 bytes)

Ross

2017-12-06 03:41

reporter   ~0104492

Added minimal project and problem file.

Alfred

2017-12-06 07:39

reporter   ~0104498

Can confirm these CRC errors.

Encountered some of them in a non-reproducable way when unzipping files that were zipped with winrar. Switched to 7zip to eliminate these CRC errors.

Ross

2017-12-06 14:10

reporter   ~0104528

Last edited: 2017-12-06 15:04

View 3 revisions

I have observed that the packed size of the file is incorrect when deflated with cldefault compression level. This is compared to a zip with 7zip at same normal compression level.
I have a sad work around for my application, I have set the compression level for the Entry to clmax when file is a dll.
This may pop up with other files that are not dll but I have only seen it with this one file so far.

Michael Van Canneyt

2018-04-01 09:32

administrator   ~0107498

Resolved using patch in 0033493

Issue History

Date Modified Username Field Change
2017-12-05 01:45 Ross New Issue
2017-12-05 14:53 Marco van de Voort Note Added: 0104454
2017-12-05 14:53 Marco van de Voort Assigned To => Marco van de Voort
2017-12-05 14:53 Marco van de Voort Status new => feedback
2017-12-06 03:38 Ross File Added: ziptest.zip
2017-12-06 03:39 Ross File Added: javafx_font_t2k.dll
2017-12-06 03:41 Ross Note Added: 0104492
2017-12-06 03:41 Ross Status feedback => assigned
2017-12-06 07:39 Alfred Note Added: 0104498
2017-12-06 09:52 Marco van de Voort Relationship added duplicate of 0031219
2017-12-06 14:10 Ross Note Added: 0104528
2017-12-06 14:14 Ross Note Edited: 0104528 View Revisions
2017-12-06 15:04 Ross Note Edited: 0104528 View Revisions
2018-03-23 22:09 Michael Van Canneyt Relationship added related to 0033493
2018-04-01 09:32 Michael Van Canneyt Fixed in Revision => 38657
2018-04-01 09:32 Michael Van Canneyt Note Added: 0107498
2018-04-01 09:32 Michael Van Canneyt Status assigned => resolved
2018-04-01 09:32 Michael Van Canneyt Fixed in Version => 3.1.1
2018-04-01 09:32 Michael Van Canneyt Resolution open => fixed
2018-04-01 09:32 Michael Van Canneyt Assigned To Marco van de Voort => Michael Van Canneyt
2018-04-01 09:32 Michael Van Canneyt Target Version => 3.2.0