View Issue Details

IDProjectCategoryView StatusLast Update
0032801FPCDatabasepublic2017-12-29 12:03
Reporterwsoft-huAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0032801: when I close IDE: Access violation
DescriptionFBAdmin in the form
when I close IDE: Access violation
TagsNo tags attached.
Fixed in Revision37857.
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0032732 resolvedJuha Manninen Packages TFBAdmin (SQLdb page) component not eraseable from the form or close project = access violation 

Activities

wsoft-hu

2017-12-09 10:43

reporter  

laz1.PNG (248,204 bytes)
laz1.PNG (248,204 bytes)

wsoft-hu

2017-12-09 10:45

reporter  

laz2.PNG (213,774 bytes)
laz2.PNG (213,774 bytes)

wp

2017-12-09 12:24

reporter   ~0104604

I can confirm the issue (Win 10/64-bit, Laz 32-bit 1.8/fpc3.04 or Laz trunk/fpc3.04).

The error occurs also if the TFBAdmin is created at runtime, like in this code (only empty form with this OnCreate handler attached):

-------------------

unit Unit1;

{$mode objfpc}{$H+}

interface

uses
  Classes, FBAdmin, SysUtils, FileUtil, Forms, Controls, Graphics, Dialogs;

type

  { TForm1 }

  TForm1 = class(TForm)
    procedure FormCreate(Sender: TObject);
  private
    fbadmin: TFBAdmin;

  public

  end;

var
  Form1: TForm1;

implementation

{$R *.lfm}

{ TForm1 }

procedure TForm1.FormCreate(Sender: TObject);
begin
  fbadmin := TFBAdmin.Create(self);
end;

end.

---------------------------

When I replace the fpc 3.04 of Laz 1.8 with fpc 3.02 then the error is gone. No problem with Laz trunk / fpc trunk

--> Seems to be an fpc issue which has been fixed in fpc trunk

Juha Manninen

2017-12-09 16:01

reporter   ~0104607

The FPC revision should be dug up and merged to their fixes branch.

wp

2017-12-12 00:37

reporter   ~0104652

Duplicate of 0032304

wp

2017-12-12 00:39

reporter   ~0104653

Last edited: 2017-12-12 00:41

View 2 revisions

Michael, could you move this report to FPC and merge r37000 to fpc-fixes? This resolved the original bugreport.

wp

2017-12-29 00:12

reporter   ~0105082

ping

Michael Van Canneyt

2017-12-29 12:03

administrator   ~0105100

Done.

Issue History

Date Modified Username Field Change
2017-12-09 10:43 wsoft-hu New Issue
2017-12-09 10:43 wsoft-hu File Added: laz1.PNG
2017-12-09 10:45 wsoft-hu File Added: laz2.PNG
2017-12-09 12:24 wp Note Added: 0104604
2017-12-09 15:56 Juha Manninen Relationship added related to 0032732
2017-12-09 16:01 Juha Manninen Note Added: 0104607
2017-12-12 00:37 wp LazTarget => -
2017-12-12 00:37 wp Note Added: 0104652
2017-12-12 00:37 wp Status new => resolved
2017-12-12 00:37 wp Resolution open => no change required
2017-12-12 00:37 wp Assigned To => wp
2017-12-12 00:39 wp Assigned To wp => Michael Van Canneyt
2017-12-12 00:39 wp Note Added: 0104653
2017-12-12 00:39 wp Status resolved => assigned
2017-12-12 00:39 wp Resolution no change required => reopened
2017-12-12 00:40 wp Status assigned => feedback
2017-12-12 00:41 wp Note Edited: 0104653 View Revisions
2017-12-29 00:12 wp Note Added: 0105082
2017-12-29 11:59 Michael Van Canneyt Project Packages => FPC
2017-12-29 12:03 Michael Van Canneyt Fixed in Revision => 37857.
2017-12-29 12:03 Michael Van Canneyt Note Added: 0105100
2017-12-29 12:03 Michael Van Canneyt Status feedback => resolved
2017-12-29 12:03 Michael Van Canneyt Fixed in Version => 3.1.1
2017-12-29 12:03 Michael Van Canneyt Resolution reopened => fixed
2017-12-29 12:03 Michael Van Canneyt Target Version => 3.2.0