View Issue Details

IDProjectCategoryView StatusLast Update
0032923FPCTextmode IDEpublic2019-02-06 03:44
ReporterLadislav LacinaAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSprobably allOS Version
Product Version3.0.4Product Build 
Target Version3.2.0Fixed in Version3.3.1 
Summary0032923: Graphic glitch in Textmode IDE in window "About"
DescriptionIn IDE in menu -- Help -- About is a graphic glitch in the "About window"
Look at screenshot (http://laaca.sweb.cz/fp_ide.png). The "OK button" is in the text - not under the text.

TagsNo tags attached.
Fixed in Revision41080
FPCOldBugId
FPCTarget
Attached Files
  • aboutDialog.patch (733 bytes)
    Index: packages/ide/fpviews.pas
    ===================================================================
    --- packages/ide/fpviews.pas	(revision 40809)
    +++ packages/ide/fpviews.pas	(working copy)
    @@ -4256,7 +4256,7 @@
       C^.Insert(NewStr(S));
     end;
     begin
    -  R.Assign(0,0,58,14{$ifdef NODEBUG}-1{$endif});
    +  R.Assign(0,0,58,14);
       inherited Init(R, dialog_about);
       HelpCtx:=hcAbout;
       GetExtent(R); R.Grow(-3,-2);
    @@ -4270,6 +4270,7 @@
     {$ifdef USE_GRAPH_SWITCH}
       Insert(New(PStaticText, Init(R2, ^C'With Graphic Support')));
       R2.Move(0,1);
    +  GrowTo(Size.X,Size.Y+1);
     {$endif USE_GRAPH_SWITCH}
       Insert(New(PStaticText, Init(R2, FormatStrStr2(^C'(%s %s)',label_about_compilerversion,Full_Version_String))));
     {$ifndef NODEBUG}
    
    aboutDialog.patch (733 bytes)
  • aboutDialog_v2.patch (448 bytes)
    Index: packages/ide/fpviews.pas
    ===================================================================
    --- packages/ide/fpviews.pas	(revision 40809)
    +++ packages/ide/fpviews.pas	(working copy)
    @@ -4256,7 +4256,7 @@
       C^.Insert(NewStr(S));
     end;
     begin
    -  R.Assign(0,0,58,14{$ifdef NODEBUG}-1{$endif});
    +  R.Assign(0,0,58,14{$ifdef USE_GRAPH_SWITCH}+1{$endif});
       inherited Init(R, dialog_about);
       HelpCtx:=hcAbout;
       GetExtent(R); R.Grow(-3,-2);
    
    aboutDialog_v2.patch (448 bytes)

Activities

Marco van de Voort

2018-01-01 23:08

manager   ~0105245

Probably resolution dependent, and I assume that is 25 lines?

Ladislav Lacina

2018-01-02 21:52

reporter   ~0105272

It appears in 50 lines mode too.

Thaddy de Koning

2018-01-03 11:30

reporter  

Thaddy de Koning

2018-01-03 11:31

reporter   ~0105281

Last edited: 2018-01-03 11:31

View 2 revisions

That's machine, distribution, terminal type and font dependent. See my screenshot. Can you try with trunk?

Marco van de Voort

2018-01-03 13:10

manager   ~0105283

I searched a bit yesterday, and I think the code is a mess. The dialog is enlarged in some cases, but some code just (like "with graphic" assumes that there is always enough space.

So basically the dialogue had a few reserved lines, but those have been eaten up by multiple parties.

The code should be reworked to first count the lines necessary, and then instantiate the window, and not make and grow as you go.

P.s. press alt-I in that window.

Ladislav Lacina

2018-01-07 16:59

reporter   ~0105443

Hm, it seems to be true that it is really terminal type and font dependend. The Win32 version in my font setting seems to be fine -- in windowed output.
But in the fullscreen platforms like Go32V2 is it present - even if I run it under Win98 and switch from fullscreen into window.

Marģers

2019-01-08 14:48

reporter  

aboutDialog.patch (733 bytes)
Index: packages/ide/fpviews.pas
===================================================================
--- packages/ide/fpviews.pas	(revision 40809)
+++ packages/ide/fpviews.pas	(working copy)
@@ -4256,7 +4256,7 @@
   C^.Insert(NewStr(S));
 end;
 begin
-  R.Assign(0,0,58,14{$ifdef NODEBUG}-1{$endif});
+  R.Assign(0,0,58,14);
   inherited Init(R, dialog_about);
   HelpCtx:=hcAbout;
   GetExtent(R); R.Grow(-3,-2);
@@ -4270,6 +4270,7 @@
 {$ifdef USE_GRAPH_SWITCH}
   Insert(New(PStaticText, Init(R2, ^C'With Graphic Support')));
   R2.Move(0,1);
+  GrowTo(Size.X,Size.Y+1);
 {$endif USE_GRAPH_SWITCH}
   Insert(New(PStaticText, Init(R2, FormatStrStr2(^C'(%s %s)',label_about_compilerversion,Full_Version_String))));
 {$ifndef NODEBUG}
aboutDialog.patch (733 bytes)

Marģers

2019-01-08 14:53

reporter   ~0113267

Last edited: 2019-01-08 15:21

View 3 revisions

Patch. If compiled with NODEBUG, then still show empty line for debugger, no need reduce window size by 1. If USE_GRAPH_SWITCH, then its add extra line, so make window high grow by 1.
Edit: aboutDialog_v2.patch is better and does the same thing.

Marģers

2019-01-08 15:17

reporter  

aboutDialog_v2.patch (448 bytes)
Index: packages/ide/fpviews.pas
===================================================================
--- packages/ide/fpviews.pas	(revision 40809)
+++ packages/ide/fpviews.pas	(working copy)
@@ -4256,7 +4256,7 @@
   C^.Insert(NewStr(S));
 end;
 begin
-  R.Assign(0,0,58,14{$ifdef NODEBUG}-1{$endif});
+  R.Assign(0,0,58,14{$ifdef USE_GRAPH_SWITCH}+1{$endif});
   inherited Init(R, dialog_about);
   HelpCtx:=hcAbout;
   GetExtent(R); R.Grow(-3,-2);
aboutDialog_v2.patch (448 bytes)

Michael Van Canneyt

2019-01-27 09:39

administrator   ~0113658

Applied, many thanks for the patch!

Issue History

Date Modified Username Field Change
2018-01-01 22:05 Ladislav Lacina New Issue
2018-01-01 23:08 Marco van de Voort Note Added: 0105245
2018-01-02 21:52 Ladislav Lacina Note Added: 0105272
2018-01-03 11:30 Thaddy de Koning File Added: Screenshot from 2018-01-03 11-29-14.png
2018-01-03 11:31 Thaddy de Koning Note Added: 0105281
2018-01-03 11:31 Thaddy de Koning Note Edited: 0105281 View Revisions
2018-01-03 13:10 Marco van de Voort Note Added: 0105283
2018-01-07 16:59 Ladislav Lacina Note Added: 0105443
2019-01-08 14:48 Marģers File Added: aboutDialog.patch
2019-01-08 14:53 Marģers Note Added: 0113267
2019-01-08 15:17 Marģers File Added: aboutDialog_v2.patch
2019-01-08 15:20 Marģers Note Edited: 0113267 View Revisions
2019-01-08 15:21 Marģers Note Edited: 0113267 View Revisions
2019-01-27 09:39 Michael Van Canneyt Fixed in Revision => 41080
2019-01-27 09:39 Michael Van Canneyt Note Added: 0113658
2019-01-27 09:39 Michael Van Canneyt Status new => resolved
2019-01-27 09:39 Michael Van Canneyt Fixed in Version => 3.3.1
2019-01-27 09:39 Michael Van Canneyt Resolution open => fixed
2019-01-27 09:39 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-01-27 09:39 Michael Van Canneyt Target Version => 3.2.0