View Issue Details

IDProjectCategoryView StatusLast Update
0032940LazarusIDEpublic2018-02-05 09:04
ReportercordylusAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.8Product Build 
Target Version1.8.2Fixed in Version1.8.2 
Summary0032940: Crash while editing code in Lazarus, InitNestInfoForIndex: FFoldNodeInfoList.Count
DescriptionThe error message is:
InitNestInfoForIndex: FFoldNodeInfoList.Count (synedithighlighterfoldbase.pas, line 1191)

The following sequences trigger it:

x = class
array of

x = class
procedure of

Outline must be enabled (in Options, Editor, Display, Markup and Matches) and the IDE must be built with debug options. Reproduces in trunk.
TagsNo tags attached.
Fixed in Revision57066, 57067
LazTarget1.8.2
Widgetset
Attached Files

Activities

Juha Manninen

2018-01-03 23:17

developer   ~0105301

The bug is already reported in 0032891.
Please provide a debugger backtrace.

Martin Friebe

2018-01-03 23:22

manager   ~0105302

Last edited: 2018-01-03 23:24

View 2 revisions

there is also a range check error, if the caret moves.

Stack trace:
  $00000000010705E2 line 1262 of synedithighlighterfoldbase.pas
  $000000000106FCA7 line 1332 of synedithighlighterfoldbase.pas
  $000000000106E97A line 1054 of synedithighlighterfoldbase.pas
  $0000000001211785 line 1428 of sourcesyneditor.pas
  $000000000073FCF7 line 307 of lazmethodlist.pas
  $0000000000FA8ABB line 951 of syneditpointclasses.pas
  $0000000000FA86B1 line 892 of syneditpointclasses.pas
  $00000000009F6415 line 2386 of synedit.pp
  $000000000073FCF7 line 307 of lazmethodlist.pas
  $0000000000FE0C19 line 1546 of synedittextbuffer.pp
  $0000000000FDDF69 line 1249 of synedittextbuffer.pp
  $0000000000FD5207 line 975 of lazsynedittext.pas
  $00000000009F5E4F line 2316 of synedit.pp
  $0000000000A0C430 line 7144 of synedit.pp
  $0000000000A08CE2 line 6486 of synedit.pp
  $00000000009F80C9 line 2931 of synedit.pp

Martin Friebe

2018-01-13 00:44

manager   ~0105724

please test and close if ok.

This is caused by
 type x = class of TFoo;

There is another issue 0033014 that causes
 type x = class something of TFoo;

to still recognize the "of".

cordylus

2018-02-05 09:04

reporter   ~0106251

Tested today. Fixed, thanks.

Issue History

Date Modified Username Field Change
2018-01-03 19:12 cordylus New Issue
2018-01-03 22:54 Martin Friebe Assigned To => Martin Friebe
2018-01-03 22:54 Martin Friebe Status new => assigned
2018-01-03 23:16 Juha Manninen Relationship added duplicate of 0032891
2018-01-03 23:17 Juha Manninen Note Added: 0105301
2018-01-03 23:22 Martin Friebe Note Added: 0105302
2018-01-03 23:24 Martin Friebe Note Edited: 0105302 View Revisions
2018-01-13 00:44 Martin Friebe Fixed in Revision => 57066
2018-01-13 00:44 Martin Friebe LazTarget => 1.8.2
2018-01-13 00:44 Martin Friebe Note Added: 0105724
2018-01-13 00:44 Martin Friebe Status assigned => resolved
2018-01-13 00:44 Martin Friebe Fixed in Version => 1.8.2
2018-01-13 00:44 Martin Friebe Resolution open => fixed
2018-01-13 00:44 Martin Friebe Target Version => 1.8.2
2018-01-13 01:00 Martin Friebe Fixed in Revision 57066 => 57066, 57067
2018-01-14 19:33 Martin Friebe Relationship deleted 0032891
2018-02-05 09:04 cordylus Note Added: 0106251
2018-02-05 09:04 cordylus Status resolved => closed