View Issue Details

IDProjectCategoryView StatusLast Update
0032947LazarusIDEpublic2018-05-23 14:28
ReporterCudaText man Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin10 
Product Version1.9 (SVN) 
Summary0032947: IDE high-dpi don't support bmp component icons
DescriptionPicture.
to see it, install [online package manager] package ATFlatControls, see Misc tab of palette.
ATFlatControls icons are:
https://github.com/Alexey-T/ATFlatControls/tree/master/atflatcontrols/res
TagsNo tags attached.
Fixed in Revision56974
LazTarget-
Widgetset
Attached Files

Relationships

related to 0033776 resolvedOndrej Pokorny IDE now ignores BMP icon trasnparency on component palette 

Activities

CudaText man

2018-01-05 10:59

reporter  

palette-dpi-bmps.png (17,276 bytes)   
palette-dpi-bmps.png (17,276 bytes)   

CudaText man

2018-01-05 11:00

reporter   ~0105374

issue is with transparent background.

wp

2018-01-05 14:21

developer   ~0105383

Last edited: 2018-01-05 18:33

View 4 revisions

I can confirm on Windows:
- unscaled system --> transparent background
- scaled (144 ppi) --> non-transparent background, like in your screenshot

Looking at the res folder in your git repository I see that you provide every palette icon only as a bmp at standard resolution (24x24). The High-DPI scaling requires palette icons to be available also at 36x36 and 48x48, and the corresponding file names must end with _150 and _200, respectivey, e.g. tatbutton.bmp (24x24), tatbutton_150.bmp (36x36), and tatbutton_200.bmp (48x48). If the additional images are not available the icons are upscaled automatically. And there seems to be a problem with bmp files here because the transparent color seems to be lost in the upscaled bitmaps.

On the other hand, if your images are 32-bit png files with alpha channel then upscaling works correctly without any issues, and the palette icons are displayed with transparent background.

This happens also if you upscale the original bmp files manually.

I am attaching the tatbutton as png in the three resolutions. I used GIMP to remove the bmp background and to upscale.

wp

2018-01-05 14:35

developer  

tatbutton-png.zip (2,508 bytes)

Ondrej Pokorny

2018-01-06 02:11

developer   ~0105396

huh, somebody using fixed-color transparent bitmaps in 2018?

fixed anyway.

Issue History

Date Modified Username Field Change
2018-01-05 10:59 CudaText man New Issue
2018-01-05 10:59 CudaText man File Added: palette-dpi-bmps.png
2018-01-05 11:00 CudaText man Note Added: 0105374
2018-01-05 14:21 wp Note Added: 0105383
2018-01-05 14:21 wp Note Edited: 0105383 View Revisions
2018-01-05 14:35 wp Note Edited: 0105383 View Revisions
2018-01-05 14:35 wp File Added: tatbutton-png.zip
2018-01-05 18:33 wp Note Edited: 0105383 View Revisions
2018-01-06 02:11 Ondrej Pokorny Fixed in Revision => 56974
2018-01-06 02:11 Ondrej Pokorny LazTarget => -
2018-01-06 02:11 Ondrej Pokorny Note Added: 0105396
2018-01-06 02:11 Ondrej Pokorny Status new => resolved
2018-01-06 02:11 Ondrej Pokorny Resolution open => fixed
2018-01-06 02:11 Ondrej Pokorny Assigned To => Ondrej Pokorny
2018-05-23 14:28 Michl Relationship added related to 0033776