View Issue Details

IDProjectCategoryView StatusLast Update
0033000LazarusIDEpublic2018-01-11 09:41
ReporterFTurtle Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN) 
Target Version1.8.2 
Summary0033000: TDBGridColumnsPropertyEditorForm: Clicking "Delete All" causes crash of IDE.
DescriptionSee steps to reproduce.
Steps To Reproduce1. Open project examples\database\dblookup\project1.lpi
2. Open Form1.
3. Double click on DBGrid1.
4. Click "Add Fields".
5. Click on any field for selecting, let it be MTH_NO
6. Click "Delete All", answer "Yes".
7. Try drag form on header.
8. Get hanging IDE with or without chain of exceptions.

Do everything exactly without anything else.
Tested under Windows.
TagsNo tags attached.
Fixed in Revisionr57042
LazTarget1.8.2
Widgetset
Attached Files

Relationships

related to 0032903 closedJuha Manninen [Patches] TDBGridColumnsPropertyEditorForm: Refactoring (step 1) 

Activities

Juha Manninen

2018-01-10 13:18

developer   ~0105618

Is this a regression or has the bug been there always?
At least it is NOT caused by r56880 (Issue 0032820). Just checked.

FTurtle

2018-01-10 13:26

reporter   ~0105619

It is very old bug.
It presents at least in 1.6.4

Juha Manninen

2018-01-10 15:32

developer   ~0105624

Fixed, please test.
Will be merged to 1.8.2.

FTurtle

2018-01-11 09:41

reporter   ~0105657

Works properly.
Thank you.

Issue History

Date Modified Username Field Change
2018-01-10 10:02 FTurtle New Issue
2018-01-10 11:14 Juha Manninen Relationship added related to 0032903
2018-01-10 13:18 Juha Manninen Note Added: 0105618
2018-01-10 13:26 FTurtle Note Added: 0105619
2018-01-10 15:29 Juha Manninen Assigned To => Juha Manninen
2018-01-10 15:29 Juha Manninen Status new => assigned
2018-01-10 15:32 Juha Manninen Fixed in Revision => r57042
2018-01-10 15:32 Juha Manninen LazTarget => -
2018-01-10 15:32 Juha Manninen Note Added: 0105624
2018-01-10 15:32 Juha Manninen Status assigned => resolved
2018-01-10 15:32 Juha Manninen Resolution open => fixed
2018-01-10 15:33 Juha Manninen LazTarget - => 1.8.2
2018-01-10 15:33 Juha Manninen Target Version => 1.8.2
2018-01-11 09:41 FTurtle Note Added: 0105657
2018-01-11 09:41 FTurtle Status resolved => closed