View Issue Details

IDProjectCategoryView StatusLast Update
0033020FPCLCLpublic2018-01-16 09:31
ReporterThaddy de Koning Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformallOSall 
Summary0033020: After FPC commit 37962 Lazarus does not build with FPC trunk.
DescriptionAfter 37962 Lazarus does not build anymore. If I revert 37962 it builds again.
Steps To ReproduceCompile laz trunk with fpc trunk after 37962

(3104) Compiling lazutf8classes.pas
/home/pi/lazarus/components/lazutils/lazutf8classes.pas(37,15) Error: (3058) There is no method in an ancestor class to be overridden: "LoadFromFile(const AnsiString);"
/home/pi/lazarus/components/lazutils/lazutf8classes.pas(54,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Makefile:2785: recipe for target 'lazutils.ppu' failed
make[1]: *** [lazutils.ppu] Error 1
make[1]: Leaving directory '/home/pi/lazarus/components/lazutils'
Makefile:3239: recipe for target 'lazutils' failed
make: *** [lazutils] Error 2
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0033021 resolvedMichael Van Canneyt 37962 has side effects for derived classes 

Activities

Thaddy de Koning

2018-01-14 09:36

reporter   ~0105773

Last edited: 2018-01-14 09:39

View 2 revisions

37962 adds encoding support to TStrings
I expect this to fail in more places than just here.

Bart Broersma

2018-01-14 15:47

reporter   ~0105793

Last edited: 2018-01-14 15:48

View 2 revisions

Should be fixed by fpc r37965.

@Thaddy: why file this in Lazarus-CCR?

Thaddy de Koning

2018-01-15 08:58

reporter   ~0105833

Because alt first glance it could be fixed either way. As of 37968 it is still broken - in fpc - btw. On second glance it should be fixed in FPC so I filed a separate report for which there was an initial fix that is also broken.

Michael Van Canneyt

2018-01-15 10:17

administrator   ~0105837

Should be fixed. Please test and close if OK.

Thaddy de Koning

2018-01-16 08:15

reporter   ~0105868

Last edited: 2018-01-16 08:16

View 3 revisions

Still does not work: It also fails on TStream inheritance, not only on TStrings inheritance..

/home/pi/lazarus/components/lazutils/lazfreetypefontcollection.pas(1068,1) Fatal: Internal error 2005091810
Fatal: (1018) Compilation aborted
Makefile:2785: recipe for target 'lazutils.ppu' failed
make[1]: *** [lazutils.ppu] Error 1
make[1]: Leaving directory '/home/pi/lazarus/components/lazutils'
Makefile:3239: recipe for target 'lazutils' failed
make: *** [lazutils] Error 2

This is with FPC r37980 Lazarus r57100
I think the default boolean parameter is not a good idea.
If I revert, it works again.

Thaddy de Koning

2018-01-16 09:02

reporter   ~0105869

Last edited: 2018-01-16 09:04

View 2 revisions

Never mind: close. I made my quarterly custom build mistake. Very sorry.
Close, please. My build farm throws no errors... Very sorry.

Issue History

Date Modified Username Field Change
2018-01-14 09:34 Thaddy de Koning New Issue
2018-01-14 09:36 Thaddy de Koning Note Added: 0105773
2018-01-14 09:39 Thaddy de Koning Note Edited: 0105773 View Revisions
2018-01-14 15:47 Bart Broersma Note Added: 0105793
2018-01-14 15:48 Bart Broersma Note Edited: 0105793 View Revisions
2018-01-14 15:48 Bart Broersma Status new => feedback
2018-01-14 15:49 Bart Broersma Project Lazarus CCR => FPC
2018-01-15 08:58 Thaddy de Koning Note Added: 0105833
2018-01-15 08:58 Thaddy de Koning Status feedback => new
2018-01-15 10:16 Michael Van Canneyt Assigned To => Michael Van Canneyt
2018-01-15 10:16 Michael Van Canneyt Status new => assigned
2018-01-15 10:17 Michael Van Canneyt Relationship added related to 0033021
2018-01-15 10:17 Michael Van Canneyt Note Added: 0105837
2018-01-15 10:17 Michael Van Canneyt Status assigned => resolved
2018-01-15 10:17 Michael Van Canneyt Resolution open => duplicate
2018-01-16 08:15 Thaddy de Koning Note Added: 0105868
2018-01-16 08:15 Thaddy de Koning Status resolved => feedback
2018-01-16 08:15 Thaddy de Koning Resolution duplicate => reopened
2018-01-16 08:15 Thaddy de Koning Note Edited: 0105868 View Revisions
2018-01-16 08:16 Thaddy de Koning Note Edited: 0105868 View Revisions
2018-01-16 09:02 Thaddy de Koning Note Added: 0105869
2018-01-16 09:02 Thaddy de Koning Status feedback => assigned
2018-01-16 09:04 Thaddy de Koning Note Edited: 0105869 View Revisions
2018-01-16 09:30 Michael Van Canneyt Status assigned => resolved
2018-01-16 09:30 Michael Van Canneyt Resolution reopened => duplicate
2018-01-16 09:31 Michael Van Canneyt Status resolved => closed