View Issue Details

IDProjectCategoryView StatusLast Update
0033021FPCRTLpublic2018-01-15 10:17
ReporterThaddy de KoningAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.1.1Product Build37962 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033021: 37962 has side effects for derived classes
DescriptionCommit 37962 has side effects for derived classes since override is broken for e.g single parameter signature LoadFromStream SaveToStream.

Manifests itself in building Lazarus trunk, but I have multiple examples in my own code tree as well.

Can it be reverted for now?
TagsNo tags attached.
Fixed in Revision37965
FPCOldBugId
FPCTarget
Attached Files

Relationships

related to 0032871 closedMichael Van Canneyt Make TStrings.LoadFromFile and .LoadFromStream Delphi-compatible 
related to 0033020 closedMichael Van Canneyt After FPC commit 37962 Lazarus does not build with FPC trunk. 

Activities

Thaddy de Koning

2018-01-14 10:11

reporter   ~0105777

Because I don't see an easy fix.

Michael Van Canneyt

2018-01-14 10:19

administrator   ~0105778

The fix is to make 2 calls. One without boolean parameter that calls the second - with parameter set to true. I will do so today.

Ondrej Pokorny

2018-01-14 11:11

developer   ~0105783

The IgnoreEncoding-overload isn't needed at all. Better not to change anything.

Michael Van Canneyt

2018-01-14 11:12

administrator   ~0105784

Hopefully fixed. Please test and close if OK.

Issue History

Date Modified Username Field Change
2018-01-14 10:10 Thaddy de Koning New Issue
2018-01-14 10:11 Thaddy de Koning Note Added: 0105777
2018-01-14 10:18 Michael Van Canneyt Assigned To => Michael Van Canneyt
2018-01-14 10:18 Michael Van Canneyt Status new => assigned
2018-01-14 10:19 Michael Van Canneyt Note Added: 0105778
2018-01-14 10:47 Michael Van Canneyt Relationship added related to 0032871
2018-01-14 11:11 Ondrej Pokorny Note Added: 0105783
2018-01-14 11:12 Michael Van Canneyt Fixed in Revision => 37965
2018-01-14 11:12 Michael Van Canneyt Note Added: 0105784
2018-01-14 11:12 Michael Van Canneyt Status assigned => resolved
2018-01-14 11:12 Michael Van Canneyt Fixed in Version => 3.1.1
2018-01-14 11:12 Michael Van Canneyt Resolution open => fixed
2018-01-14 11:12 Michael Van Canneyt Target Version => 3.2.0
2018-01-15 10:17 Michael Van Canneyt Relationship added related to 0033020