View Issue Details

IDProjectCategoryView StatusLast Update
0033101LazarusLCLpublic2020-10-10 19:08
ReporterJean Patrick Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinux 64-bitOSLinux 
Product Version1.8 
Summary0033101: TSpinEdit is not working properly on Linux
DescriptionWhen the "MinValue" property of a TSpinEdit is changed to certain values, you can not type on keyboard a value between the minimum and maximum.

For example:
If set up:
MinValue: = 100;
MaxValue: = 200;

Only allows type on keyboard 100 or 200. It does not allow type on: 101, 102, 103, ...

NOTE: You only can change using the cursor arrows or the component buttons.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0028123 assignedZeljan Rikalo Patches TFloatSpinEdit, TSpinEdit: Cannot enter value as expected 

Activities

Vojtech Cihak

2018-01-30 16:57

reporter   ~0106128

I can confirm wirh Lazarus 1.9.0 r57186M and FPC 3.0.4.

Bart Broersma

2018-02-04 14:02

developer   ~0106224

Last edited: 2018-02-04 14:03

View 2 revisions

Constraints (MinValue/MaxValue) are applied on each OnChange.
Example: Minvalue=100, Text = 100, delete last zero, Value becomes 10, which will be reset to MinValue.
This should be prevented when you are typing in the control.

See 0028123

Bart Broersma

2018-02-04 14:04

developer   ~0106225

As a workaround you can use T(Float)SpinEditEx from LazControls.

Issue History

Date Modified Username Field Change
2018-01-30 16:37 Jean Patrick New Issue
2018-01-30 16:57 Vojtech Cihak Note Added: 0106128
2018-02-04 14:02 Bart Broersma Note Added: 0106224
2018-02-04 14:02 Bart Broersma Relationship added related to 0028123
2018-02-04 14:03 Bart Broersma Note Edited: 0106224 View Revisions
2018-02-04 14:04 Bart Broersma Note Added: 0106225
2020-10-10 19:08 Bart Broersma Assigned To => Bart Broersma
2020-10-10 19:08 Bart Broersma Status new => resolved
2020-10-10 19:08 Bart Broersma Resolution open => duplicate
2020-10-10 19:08 Bart Broersma LazTarget => -
2020-10-10 19:08 Bart Broersma Widgetset GTK 2 => GTK 2
2020-10-10 19:08 Bart Broersma Relationship replaced duplicate of 0028123