View Issue Details

IDProjectCategoryView StatusLast Update
0033122LazarusWidgetsetpublic2020-04-16 14:32
ReporterZeljan Rikalo Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0033122: Qt, Qt5: Menu item Bitmap issues
DescriptionSame thing as issue 33099.
TagsNo tags attached.
Fixed in Revision62882
LazTarget-
WidgetsetQT, QT5
Attached Files

Relationships

related to 0033099 closedOndrej Pokorny Menu item Bitmap issues 

Activities

Zeljan Rikalo

2018-02-03 18:24

developer   ~0106203

@Ondrej, I've assigned this to you, since it's hidpiimglist related.

Ondrej Pokorny

2018-02-03 18:26

developer   ~0106204

What problems in particular?

Ondrej Pokorny

2018-02-03 18:45

developer   ~0106205

> What problems in particular?

Why I ask:

1.) The icon in the menu is not transparent - this is not hidpiimglist related (neither Gtk2 nor win32 nor Qt ...). The bug is present at least in 1.6 as well - probably since the very beginning.

2.) unreleased DCs: I don't see any code changes in Qt that affect DCs and I don't get any error messages about unreleased DCs. Can you be more specific what problems you face?

Ondrej Pokorny

2018-02-03 18:57

developer   ~0106206

Sorry, I have to unasign.

1.) The icon in the menu is not transparent - see TQtWSMenuItem.CreateMenuFromMenuItem -> if TMenuItem.Bitmap is set, TImageList is not involved. This bug is much older than the High-DPI image list.

I assume you need to create a 32bit bitmap (take down left corner as transparent color) and send it to Result.setImage(TQtImage(AMenuItem.Bitmap.Handle));

2.) unreleased DCs: As I said before, I don't see a problem with my changes here.

Zeljan Rikalo

2018-02-03 19:07

developer   ~0106207

Ok, sorry , I'll fix it then

Issue History

Date Modified Username Field Change
2018-02-03 18:22 Zeljan Rikalo New Issue
2018-02-03 18:22 Zeljan Rikalo Relationship added related to 0033099
2018-02-03 18:24 Zeljan Rikalo Note Added: 0106203
2018-02-03 18:24 Zeljan Rikalo Assigned To => Ondrej Pokorny
2018-02-03 18:24 Zeljan Rikalo Status new => assigned
2018-02-03 18:26 Ondrej Pokorny Note Added: 0106204
2018-02-03 18:45 Ondrej Pokorny Note Added: 0106205
2018-02-03 18:54 Ondrej Pokorny Assigned To Ondrej Pokorny =>
2018-02-03 18:57 Ondrej Pokorny Note Added: 0106206
2018-02-03 18:57 Ondrej Pokorny Status assigned => new
2018-02-03 19:07 Zeljan Rikalo Note Added: 0106207
2018-02-03 19:07 Zeljan Rikalo Assigned To => Zeljan Rikalo
2018-02-03 19:07 Zeljan Rikalo Status new => assigned
2020-04-04 14:13 Zeljan Rikalo Status assigned => resolved
2020-04-04 14:13 Zeljan Rikalo Resolution open => fixed
2020-04-04 14:13 Zeljan Rikalo Fixed in Revision => 62882
2020-04-04 14:13 Zeljan Rikalo Widgetset QT, QT5 => QT, QT5
2020-04-16 14:32 Zeljan Rikalo Status resolved => closed