View Issue Details

IDProjectCategoryView StatusLast Update
0033156FPCDocumentationpublic2018-05-14 20:17
ReporterMarco van de VoortAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.0.4Product Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033156: Set sizes in Delphi mode undocumented
DescriptionIn one of the later versions (2.4, 2.6?) setsizes that truly map to Delphi sizes (growing with one byte at a time) were implemented. The documentation
doesn't seem to reflect that.

https://www.freepascal.org/docs-html/ref/refsu16.html#x40-580003.3.3

backlink forum where Thaddy remarked on that: http://forum.lazarus-ide.org/index.php/topic,31074.15.html
Steps To Reproduce    {$mode delphi}
     
    type txxx = set of 0..247;
     
    begin
      writeln(sizeof(txxx));
    end.

  prints "31".
TagsNo tags attached.
Fixed in Revision1463
FPCOldBugId0
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2018-02-24 13:47

administrator   ~0106563

Adapted programmer's guide and replaced language reference guide explanation with reference to the programmer's guide. (since there are directives that control the size: $PACKSET.

Issue History

Date Modified Username Field Change
2018-02-11 13:52 Marco van de Voort New Issue
2018-02-11 13:52 Marco van de Voort Status new => assigned
2018-02-11 13:52 Marco van de Voort Assigned To => Michael Van Canneyt
2018-02-24 13:47 Michael Van Canneyt Fixed in Revision => 1463
2018-02-24 13:47 Michael Van Canneyt Note Added: 0106563
2018-02-24 13:47 Michael Van Canneyt Status assigned => resolved
2018-02-24 13:47 Michael Van Canneyt Fixed in Version => 3.1.1
2018-02-24 13:47 Michael Van Canneyt Resolution open => fixed
2018-02-24 13:47 Michael Van Canneyt Target Version => 3.2.0
2018-05-14 20:17 Marco van de Voort Status resolved => closed