View Issue Details

IDProjectCategoryView StatusLast Update
0033243LazarusPackagespublic2018-02-27 18:25
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version1.9 (SVN)Product Build 
Target VersionFixed in Version 
Summary0033243: FPReport designer: The save button acts sometimes like Save and at other times like Save As
DescriptionThe save button in the standalone designer acts sometimes like Save and at other times like Save As.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0033239 closedMichael Van Canneyt FPReport designer: designer asks to save an already saved report before exiting 
related to 0033240 closedMichael Van Canneyt FPReport designer: Resaving a loaded report will ask for the filename 

Activities

Michael Van Canneyt

2018-02-27 09:26

administrator   ~0106659

Can you be more precise, please ? Steps to reproduce ?

Stephano

2018-02-27 09:32

developer   ~0106660

Once issues 0033239 and 0033240 are resolved, I can try to make a reproducible case. For the time being, the mentioned bugs get in the way.

Stephano

2018-02-27 11:06

developer   ~0106665

Steps to reproduce:
- Launch the designer
- Open a previously saved report
- Add a memo to a data band
- Click the save toolbutton
The designer will ask for the filename and folder.
- Add another memo
- Click the save toolbutton
The designer will not ask this time

Michael Van Canneyt

2018-02-27 15:06

administrator   ~0106679

This is a duplicate of the 2 related reports. Fixing those, fixed this.

Issue History

Date Modified Username Field Change
2018-02-27 09:23 Stephano New Issue
2018-02-27 09:25 Stephano Relationship added related to 0033239
2018-02-27 09:25 Stephano Relationship added related to 0033240
2018-02-27 09:26 Michael Van Canneyt Assigned To => Michael Van Canneyt
2018-02-27 09:26 Michael Van Canneyt Status new => assigned
2018-02-27 09:26 Michael Van Canneyt Note Added: 0106659
2018-02-27 09:27 Michael Van Canneyt Status assigned => feedback
2018-02-27 09:32 Stephano Note Added: 0106660
2018-02-27 09:32 Stephano Status feedback => assigned
2018-02-27 11:06 Stephano Note Added: 0106665
2018-02-27 15:06 Michael Van Canneyt Note Added: 0106679
2018-02-27 15:06 Michael Van Canneyt Status assigned => resolved
2018-02-27 15:06 Michael Van Canneyt Resolution open => duplicate
2018-02-27 18:25 Stephano Status resolved => closed