View Issue Details

IDProjectCategoryView StatusLast Update
0033247LazarusPackagespublic2018-02-28 09:40
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0033247: FPReport designer: Impossible to assign a Data property in the OI
Description- Create a new report
- Create new report data (SQLDB/Firebird) as Data1, and make sure its data is displayed when the show data button is pressed.
- Select the page
- Try to assign the Data property.
Data1 will be displayed in the dropdown list, but the Data property will remain blank no matter what.
The same happens if a databand is added and one tries to set its Data property.
TagsNo tags attached.
Fixed in Revision57406
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0033248 closedMichael Van Canneyt FPReport designer: Relationship between bands cannot be set 

Activities

Michael Van Canneyt

2018-02-27 17:20

administrator   ~0106686

Same issue as 33248.

Stephano

2018-02-27 19:56

developer   ~0106703

I still can't see the assignment in the OI, though when it's supposed to be assigned, the value is pinkish instead of white.

Stephano

2018-02-27 21:36

developer   ~0106707

I forgot to add that although the assignment is not visible, and the only indication is the pinkish color, the Data property gets assigned indeed.

Michael Van Canneyt

2018-02-28 08:51

administrator   ~0106718

Fixed, same issue as with bands.

Issue History

Date Modified Username Field Change
2018-02-27 10:03 Stephano New Issue
2018-02-27 11:23 Michael Van Canneyt Assigned To => Michael Van Canneyt
2018-02-27 11:23 Michael Van Canneyt Status new => assigned
2018-02-27 17:20 Michael Van Canneyt Fixed in Revision => 57395.
2018-02-27 17:20 Michael Van Canneyt Note Added: 0106686
2018-02-27 17:20 Michael Van Canneyt Relationship added duplicate of 0033248
2018-02-27 17:20 Michael Van Canneyt Status assigned => resolved
2018-02-27 17:20 Michael Van Canneyt Fixed in Version => 1.9 (SVN)
2018-02-27 17:20 Michael Van Canneyt Resolution open => duplicate
2018-02-27 19:56 Stephano Note Added: 0106703
2018-02-27 19:56 Stephano Status resolved => assigned
2018-02-27 19:56 Stephano Resolution duplicate => reopened
2018-02-27 21:36 Stephano Note Added: 0106707
2018-02-28 08:51 Michael Van Canneyt Fixed in Revision 57395. => 57406
2018-02-28 08:51 Michael Van Canneyt Note Added: 0106718
2018-02-28 08:51 Michael Van Canneyt Status assigned => resolved
2018-02-28 08:51 Michael Van Canneyt Resolution reopened => fixed
2018-02-28 09:40 Stephano Status resolved => closed