View Issue Details

IDProjectCategoryView StatusLast Update
0033287LazarusPackagespublic2018-03-04 13:18
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0033287: FPReport IDE designer: Modified flag starts on the wrong foot
Description- Create a new Lazarus project
- Add a TFPReport to the form
- Double click FPReport1
The title bar and status bar will show that the modified flag is set
Otherwise the modified flag seems to work fine
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Stephano

2018-03-03 13:45

developer   ~0106833

The symptom has disappeared since bug 0033288 was resolved.
Pls mark as resolved if all aspects are done with.

Michael Van Canneyt

2018-03-04 13:17

administrator   ~0106853

As far as I can test, the flag now works correctly.

It's an open question whether adding a page if there are none at startup should set the modified flag. I think not, but this is debatable.

Issue History

Date Modified Username Field Change
2018-03-01 07:23 Stephano New Issue
2018-03-01 08:00 Stephano Assigned To => Michael Van Canneyt
2018-03-01 08:00 Stephano Status new => assigned
2018-03-03 13:45 Stephano Note Added: 0106833
2018-03-04 13:17 Michael Van Canneyt Note Added: 0106853
2018-03-04 13:17 Michael Van Canneyt Status assigned => resolved
2018-03-04 13:17 Michael Van Canneyt Fixed in Version => 1.9 (SVN)
2018-03-04 13:17 Michael Van Canneyt Resolution open => fixed
2018-03-04 13:18 Stephano Status resolved => closed