View Issue Details

IDProjectCategoryView StatusLast Update
0033311FPCCompilerpublic2018-03-03 17:49
ReporterRichard Shaw Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSFedora 
Product Version3.0.4 
Fixed in Version3.1.1 
Summary0033311: SIGSEGV during game shutdown with hedgewars 0.9.23 (hwengine)
DescriptionDuring game shutdown (freeing resources) a segmentation fault occurs.

The problem appears to be the compiler not keeping %rsp 16-byte aligned.
Steps To Reproduce1. Play a game
2. Game finishes
3. SIGSEGV on exit.
Additional InformationThe full bug report on Fedora:

https://bugzilla.redhat.com/show_bug.cgi?id=1526848

The following comment identifies the likely problem:

https://bugzilla.redhat.com/show_bug.cgi?id=1526848#c7
TagsNo tags attached.
Fixed in Revision38400
FPCOldBugId
FPCTarget
Attached Files

Activities

Florian

2018-03-03 16:40

administrator   ~0106838

I think this is not a duplicate, as this one is about x86-64.

Florian

2018-03-03 17:20

administrator   ~0106839

I did not test with hedgewars but recently solved a similiar problem when gprof is used so the fix should be fine.

Jonas Maebe

2018-03-03 17:49

manager   ~0106842

Oh yes, sorry...

Issue History

Date Modified Username Field Change
2018-03-03 16:13 Richard Shaw New Issue
2018-03-03 16:18 Jonas Maebe Relationship added duplicate of 0015582
2018-03-03 16:19 Jonas Maebe Status new => resolved
2018-03-03 16:19 Jonas Maebe Resolution open => duplicate
2018-03-03 16:19 Jonas Maebe Assigned To => Jonas Maebe
2018-03-03 16:40 Florian Note Added: 0106838
2018-03-03 16:40 Florian Assigned To Jonas Maebe =>
2018-03-03 16:40 Florian Status resolved => new
2018-03-03 17:20 Florian Fixed in Revision => 38400
2018-03-03 17:20 Florian Note Added: 0106839
2018-03-03 17:20 Florian Status new => resolved
2018-03-03 17:20 Florian Fixed in Version => 3.1.1
2018-03-03 17:20 Florian Resolution duplicate => fixed
2018-03-03 17:20 Florian Assigned To => Florian
2018-03-03 17:20 Florian Relationship deleted 0015582
2018-03-03 17:49 Jonas Maebe Note Added: 0106842