View Issue Details

IDProjectCategoryView StatusLast Update
0033333LazarusPackagespublic2018-03-22 10:43
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0033333: FPReport: Bands positioning
DescriptionIssue1:
Report summary band (on last page) is currently positioned before the column footer band.

Issue2:
Once issue1 is resolved, the positioning as far as data is concerned becomes:
- Column header
- Data header
- Group header
- Data
- Group footer
- Data footer
- Column footer
I am not sure this is the right order, as column headers usually hold the column titles (on each page). I can't think of what could come in between the titles and the data, especially on the first and last pages. In particular, the data header usually holds a description of what the data is about, and the data footer a conclusion about the data.

The above depends on my interpretation of the different band types.
TagsNo tags attached.
Fixed in Revision57456
LazTarget-
Widgetset
Attached Files

Activities

Michael Van Canneyt

2018-03-06 08:43

administrator   ~0106910

What is the bug ?
1. The report summary band should be before the column footer, this is as designed ?

2. This is the correct order.

Stephano

2018-03-06 08:59

developer   ~0106915

1-
 * The report title comes before the column header, hence it is only logical that the report summary come after the column footer.
 * Why would a column footer come after the report summary to start with? The report summary is the conclusion of the whole report (page header/footer excluded).
2- Let's assume we have field columns such as employee number and name. I would expect that each field column gets its header on each page to be able to identify what the field is. What can the data header (on the 1st page) hold to fit squeeze itself between the field headers and the fields?

Of course this is based on how I perceive the role of these bands. The design intent could be different.

Stephano

2018-03-06 09:21

developer   ~0106917

Add to the above that the report designer shows the Data header band above the Group header band, while it's vice versa in the preview.

Stephano

2018-03-06 10:12

developer   ~0106923

Now that i am able to test the group header/footer bands, i am not sure whether field headers should be placed on the column header band or the group header band. Maybe a detailed description of the usage of each band can help?

Michael Van Canneyt

2018-03-06 13:58

administrator   ~0106940

Field headers: it all depends what you want to see.
There is no right or wrong approach.

The bands are described in 'types of bands' on http://wiki.freepascal.org/FPReport. What more info do you need ?

Stephano

2018-03-06 14:14

developer   ~0106942

Band information in the wiki is vague. For instance, are the column header/footer printed on each page or not?
IIRC, and as of this morning, the column header/footer were being printed only on the first and last page respectively. Now the behavior seems to have changed as they are being printed on every page, which is good.
Now let's suppose we are printing a long list of employees. One might think of including in the column header and footer the field headings such as "name", "dept", etc... In that case the column footer on the last page looks quite odd being output after the report summary.
It's all subjective anyway.

Stephano

2018-03-06 14:26

developer  

EmployeeColumnHeaders.json (20,588 bytes)

Stephano

2018-03-06 14:26

developer   ~0106943

A simple column header/footer example is attached.

Michael Van Canneyt

2018-03-06 14:27

administrator   ~0106944

if the column header/footer are said to be printed on the top/bottom of each column, then it automatically follows they should be printed on each page ?
Well, I have added this to the wiki, to be more explicit.

It was initially certainly so.
If they were not at some point this was a bug.

If you want to see more exact information, tell me what you want to see, and I will add it. For me it is all perfectly clear and obvious, but that's logical, since I designed it...

Stephano

2018-03-06 14:36

developer   ~0106946

Let me first understand/criticize the bands operation as they are, then I can go over the wiki and spot missing/ambiguous info.

Pls have a look at the attached sample for the contrast of column footer and report summary.

Michael Van Canneyt

2018-03-06 14:53

administrator   ~0106948

I see what you mean. I have switched the order.

Note that you can do a lot of things 'wrong' by setting various options.
(Set e.g. columncount to 2 and set BandPosition to bpNormal for column footer.)

If you think things should be added to the wiki, feel free to make specific bugreports, or update the wiki, that is why it is a wiki :)

Stephano

2018-03-06 15:04

developer   ~0106949

Maybe fpc needs an update too, as the column footer/report summary order is correct in the designer only, and not in the preview.

Michael Van Canneyt

2018-03-06 15:20

administrator   ~0106952

In the preview it is correct and as intended.

Issue History

Date Modified Username Field Change
2018-03-06 08:17 Stephano New Issue
2018-03-06 08:17 Stephano Status new => assigned
2018-03-06 08:17 Stephano Assigned To => Michael Van Canneyt
2018-03-06 08:43 Michael Van Canneyt Note Added: 0106910
2018-03-06 08:43 Michael Van Canneyt Status assigned => feedback
2018-03-06 08:59 Stephano Note Added: 0106915
2018-03-06 08:59 Stephano Status feedback => assigned
2018-03-06 09:21 Stephano Note Added: 0106917
2018-03-06 10:12 Stephano Note Added: 0106923
2018-03-06 13:58 Michael Van Canneyt Note Added: 0106940
2018-03-06 14:14 Stephano Note Added: 0106942
2018-03-06 14:26 Stephano File Added: EmployeeColumnHeaders.json
2018-03-06 14:26 Stephano Note Added: 0106943
2018-03-06 14:27 Michael Van Canneyt Note Added: 0106944
2018-03-06 14:36 Stephano Note Added: 0106946
2018-03-06 14:53 Michael Van Canneyt Fixed in Revision => 57456
2018-03-06 14:53 Michael Van Canneyt Note Added: 0106948
2018-03-06 14:53 Michael Van Canneyt Status assigned => resolved
2018-03-06 14:53 Michael Van Canneyt Fixed in Version => 1.9 (SVN)
2018-03-06 14:53 Michael Van Canneyt Resolution open => fixed
2018-03-06 15:04 Stephano Note Added: 0106949
2018-03-06 15:04 Stephano Status resolved => assigned
2018-03-06 15:04 Stephano Resolution fixed => reopened
2018-03-06 15:20 Michael Van Canneyt Note Added: 0106952
2018-03-06 15:20 Michael Van Canneyt Status assigned => resolved
2018-03-06 15:20 Michael Van Canneyt Resolution reopened => fixed
2018-03-22 10:43 Stephano Status resolved => closed