View Issue Details

IDProjectCategoryView StatusLast Update
0033357FPCPackagespublic2018-03-08 19:05
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target Version3.2.0Fixed in Version3.1.1 
Summary0033357: FPReport designer: Aggregate variabless produce odd errors
Description- Preview the attached report
The preview runs fine
- Preview it a second time
-> Error: Value handler for variable SalarySum returned wrong type, expected "rtFloat", got "rtBoolean".
- Press OK
- Preview it a third time
-> Error: The report design contains 85 errors:
Band "" has no data assigned.
Band "" has no data assigned.
Band "" has no data assigned.
...
TagsNo tags attached.
Fixed in Revision38459
FPCOldBugId
FPCTarget
Attached Files

Activities

Stephano

2018-03-07 08:37

developer  

EmployeeAggregatesTest.json (39,507 bytes)

Stephano

2018-03-07 11:40

developer   ~0106973

The error seems to be caused by the aggregate variable with reset type=None. The error disappears if the reset type is set to Group instead, while leaving the reset itself blank

Michael Van Canneyt

2018-03-08 18:07

administrator   ~0107013

Fixed both issues. Most likely the 2nd issue also fixes the memory leaks I was experiencing.

Issue History

Date Modified Username Field Change
2018-03-07 08:31 Stephano New Issue
2018-03-07 08:31 Stephano Status new => assigned
2018-03-07 08:31 Stephano Assigned To => Michael Van Canneyt
2018-03-07 08:31 Stephano File Added: EmployeeAggregatesTest.json
2018-03-07 08:31 Stephano Severity minor => major
2018-03-07 08:37 Stephano File Deleted: EmployeeAggregatesTest.json
2018-03-07 08:37 Stephano File Added: EmployeeAggregatesTest.json
2018-03-07 11:40 Stephano Note Added: 0106973
2018-03-08 18:06 Michael Van Canneyt Project Lazarus => FPC
2018-03-08 18:07 Michael Van Canneyt Fixed in Revision => 38459
2018-03-08 18:07 Michael Van Canneyt Note Added: 0107013
2018-03-08 18:07 Michael Van Canneyt Status assigned => resolved
2018-03-08 18:07 Michael Van Canneyt Fixed in Version => 3.1.1
2018-03-08 18:07 Michael Van Canneyt Resolution open => fixed
2018-03-08 18:07 Michael Van Canneyt Target Version => 3.2.0
2018-03-08 19:05 Stephano Status resolved => closed