View Issue Details

IDProjectCategoryView StatusLast Update
0033362LazarusPackagespublic2018-03-09 10:22
ReporterStephanoAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.9 (SVN)Product Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0033362: FPReport designer: Add option to shrink the band to exactly accommodate its elements
DescriptionAfter placing elements on a band, one might want to manually shrink the band in the designer so that it accommodates its elements exactly.

As for the report preview, the stretchmode smActualHeight stretches but doesn't shrink the band. If this is a bug, I'll open a separate report. If it's a missing feature, should i open a separate report?
TagsNo tags attached.
Fixed in Revision57481
LazTarget-
Widgetset
Attached Files

Activities

Michael Van Canneyt

2018-03-07 09:19

administrator   ~0106968

StretchMode only stretches, i.e. makes it larger, so this is as designed.

I don't see the use of letting it shrink as well, because you can create the band with minimal size and set stretchmode to let it grow. But if you think it is better to let it shrink as well, file a separate bugreport.

Stephano

2018-03-07 09:33

developer   ~0106969

Working with thin design bands can be tricky at times and increases the cramming. I'd rather design on a thicker band and have it shrink accordingly. I'll open a separate bug report.

Michael Van Canneyt

2018-03-09 09:34

administrator   ~0107027

Added option to resize menu

Issue History

Date Modified Username Field Change
2018-03-07 09:13 Stephano New Issue
2018-03-07 09:13 Stephano Status new => assigned
2018-03-07 09:13 Stephano Assigned To => Michael Van Canneyt
2018-03-07 09:19 Michael Van Canneyt Note Added: 0106968
2018-03-07 09:33 Stephano Note Added: 0106969
2018-03-09 09:34 Michael Van Canneyt Fixed in Revision => 57481
2018-03-09 09:34 Michael Van Canneyt Note Added: 0107027
2018-03-09 09:34 Michael Van Canneyt Status assigned => resolved
2018-03-09 09:34 Michael Van Canneyt Fixed in Version => 1.9 (SVN)
2018-03-09 09:34 Michael Van Canneyt Resolution open => fixed
2018-03-09 10:22 Stephano Status resolved => closed